summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2015-06-14 03:05:30 -0300
committerFernando Manfredi2015-06-14 03:05:30 -0300
commit70a5a3d6016bcb8598ab3450fdc1fac865b7d5fa (patch)
tree3a8c60f33399ccd24143e8c2ba807b33bf8f3278
downloadaur-70a5a3d6016bcb8598ab3450fdc1fac865b7d5fa.tar.gz
Initial commit, release v1.4.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cf63ee8c14f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mount-gtk
+ pkgdesc = A simple graphical front end for udisks and mount in GTK3
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://mount-gtk.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = c++-gtk-utils>=2.0.9
+ depends = gtk3>=2.99.0
+ depends = udisks2>=1.94.0
+ optdepends = libnotify: error notifications
+ options = !buildflags
+ source = http://downloads.sourceforge.net/mount-gtk/mount-gtk-1.4.3.tar.gz
+ sha256sums = 6a245837c68214c133af96239aa772461074e57115a229ec695b2d5dbd9d2fe6
+
+pkgname = mount-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a95923799417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Acidhub <acidhub@craft.net.br>
+
+pkgname=mount-gtk
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="A simple graphical front end for udisks and mount in GTK3"
+arch=('i686' 'x86_64')
+url="http://mount-gtk.sourceforge.net/"
+license=('GPL')
+depends=('c++-gtk-utils>=2.0.9' 'gtk3>=2.99.0' 'udisks2>=1.94.0')
+optdepends=('libnotify: error notifications')
+options=('!buildflags')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('6a245837c68214c133af96239aa772461074e57115a229ec695b2d5dbd9d2fe6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}