summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 08:05:08 -0600
committerMark Wagie2022-04-15 08:05:08 -0600
commit2b9ebdfc5b7bddb016a009084bc69858651a406d (patch)
tree89dc507120a828ed5897151f75be1900a876a8b7
parentecb3eba238ddaffe77f4106bfd2fb8ed0df9c005 (diff)
downloadaur-2b9ebdfc5b7bddb016a009084bc69858651a406d.tar.gz
correct arch, disable appstream test
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e07a963b3a94..7fb173236958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = mousai
pkgdesc = Simple application for identifying songs
pkgver = 0.6.6
- pkgrel = 3
+ pkgrel = 4
url = https://apps.gnome.org/app/io.github.seadve.Mousai
- arch = x86_64
+ arch = any
license = GPL3
checkdepends = appstream-glib
makedepends = meson
depends = gstreamer
- depends = gtk4
depends = libadwaita
depends = python-gobject
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index bb5f2f917bce..94b4fc0a3666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=mousai
pkgver=0.6.6
-pkgrel=3
+pkgrel=4
pkgdesc="Simple application for identifying songs"
-arch=('x86_64')
+arch=('any')
url="https://apps.gnome.org/app/io.github.seadve.Mousai"
license=('GPL3')
-depends=('gstreamer' 'gtk4' 'libadwaita' 'python-gobject' 'python-requests')
+depends=('gstreamer' 'libadwaita' 'python-gobject' 'python-requests')
makedepends=('meson')
checkdepends=('appstream-glib')
source=("$pkgname-$pkgver.tar.gz::https://github.com/SeaDve/Mousai/archive/refs/tags/v$pkgver.tar.gz")
@@ -18,7 +18,9 @@ build() {
}
check() {
- meson test -C build --print-errorlogs
+
+ # Validate appstream file test fails
+ meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
}
package() {