summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-31 11:13:53 -0600
committerMark Wagie2021-03-31 11:13:53 -0600
commit987c5f1b6d2983f64038795255a00583da53cd4e (patch)
treeddca6d6b583d2dac1dafb8f0c0eb2bf882de4902
downloadaur-987c5f1b6d2983f64038795255a00583da53cd4e.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD26
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af7d94eff1d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mousai
+ pkgdesc = Simple application for identifying songs
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/SeaDve/Mousai
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = meson
+ depends = gstreamer
+ depends = gtk3
+ depends = libhandy
+ depends = python-gobject
+ depends = python-requests
+ source = mousai-0.2.0.tar.gz::https://github.com/SeaDve/Mousai/archive/refs/tags/v0.2.0.tar.gz
+ sha256sums = dba48c55939caeb211893c026339561134f3c712b2d3f8d2348f6d8183ccf4d3
+
+pkgname = mousai
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77e9b16a8fec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=mousai
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Simple application for identifying songs"
+arch=('x86_64')
+url="https://github.com/SeaDve/Mousai"
+license=('GPL3')
+depends=('gstreamer' 'gtk3' 'libhandy' 'python-gobject' 'python-requests')
+makedepends=('meson')
+checkdepends=('appstream-glib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('dba48c55939caeb211893c026339561134f3c712b2d3f8d2348f6d8183ccf4d3')
+
+build() {
+ arch-meson Mousai-$pkgver build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}