summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandoragon2020-09-20 19:17:05 +0200
committerRandoragon2020-09-20 19:17:05 +0200
commit5c4c3f2d368eb515bf6ad231bc82fa84fe0d3640 (patch)
tree5d513b621ada3915d4af69505c45a2698c7bd659
downloadaur-5c4c3f2d368eb515bf6ad231bc82fa84fe0d3640.tar.gz
Init commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64e23a2e0ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mousemode
+ pkgdesc = An intuitive, home-row mouse replacement
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/randoragon/mousemode
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = gcc
+ depends = libx11
+ depends = libxtst
+ depends = xorgproto
+ source = git+https://github.com/randoragon/mousemode
+ md5sums = SKIP
+
+pkgname = mousemode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c63b1fc1992f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Randoragon <randoragongamedev@gmail.com>
+pkgname=mousemode
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="An intuitive, home-row mouse replacement"
+arch=('x86_64')
+url="https://github.com/randoragon/mousemode"
+license=('MIT')
+depends=(libx11 libxtst xorgproto)
+makedepends=(git gcc)
+source=("git+$url")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/" PREFIX=/usr/bin install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 README.MD "$pkgdir/usr/share/doc/$pkgname/README.MD"
+}
+