summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2016-09-07 21:39:07 +0200
committerFrederic Bezies2016-09-07 21:39:07 +0200
commit9e26f3c45e818f319f52a848a8a837515c4c51ca (patch)
treecc6ae1022dcff8f966b8d92365dc99aa8928c422
downloadaur-9e26f3c45e818f319f52a848a8a837515c4c51ca.tar.gz
initial import from AUR with a lot of cleanup !
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddab552e7ea3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Sep 7 19:38:54 UTC 2016
+pkgbase = mousepad-git
+ pkgdesc = Mousepad development version, gtk3 only version
+ pkgver = 0.4.0.r114.gedbe8b6
+ pkgrel = 1
+ url = http://www.xfce.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xfce4-dev-tools
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = gettext
+ depends = desktop-file-utils
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = gtksourceview3
+ depends = exo
+ provides = mousepad
+ conflicts = mousepad
+ conflicts = mousepad-gtk3
+ source = git://git.xfce.org/apps/mousepad/
+ md5sums = SKIP
+
+pkgname = mousepad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96ae1979489b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: swanson <webaake gmail com>
+
+pkgname=mousepad-git
+_pkgname=mousepad
+pkgver=0.4.0.r114.gedbe8b6
+pkgrel=1
+pkgdesc="Mousepad development version, gtk3 only version"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL')
+depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'gtksourceview3' 'exo' )
+makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'gettext')
+provides=('mousepad')
+conflicts=('mousepad' 'mousepad-gtk3')
+source=(git://git.xfce.org/apps/mousepad/)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/${_pkgname}
+ git describe --long | sed 's/^mousepad-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/${_pkgname}
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --disable-static \
+ --disable-debug
+
+ make
+}
+
+package() {
+
+ cd $srcdir/${_pkgname}
+ make DESTDIR="$pkgdir" install
+}
+
+