summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEbrahim Azarisooreh2016-07-30 17:24:02 -0700
committerEbrahim Azarisooreh2016-07-30 18:09:52 -0700
commit6d5813871d344e6730b59ccc61a341034f1ff4a2 (patch)
treef92b7256c5af5c9c0008c688573b61e0a5a683c2
downloadaur-6d5813871d344e6730b59ccc61a341034f1ff4a2.tar.gz
Initial commit v1.0.0.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--mousetrap.install4
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1f6a5c27d4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mousetrap
+ pkgdesc = An X11 utility that hides the mouse pointer after a specified interval of time
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/eazar001/mousetrap
+ install = mousetrap.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ depends = python-evdev
+ depends = python
+ provides = mousetrap
+ source = https://github.com/eazar001/mousetrap/archive/1.0.0.tar.gz
+ md5sums = a63b8e7aa0c496f7f84bcc479db34a14
+
+pkgname = mousetrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..547ebc1106a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ebrahim Azarisooreh <ebrahim.azarisooreh@gmail.com>
+pkgname=mousetrap
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="An X11 utility that hides the mouse pointer after a specified interval of time"
+arch=('x86_64' 'i686')
+url="https://github.com/eazar001/mousetrap"
+license=('MIT')
+depends=('python-evdev' 'libx11')
+makedepends=('cargo' 'rust')
+provides=('mousetrap')
+backup=()
+options=()
+install=mousetrap.install
+source=("https://github.com/eazar001/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('a63b8e7aa0c496f7f84bcc479db34a14')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/mousetrap.install b/mousetrap.install
new file mode 100644
index 000000000000..37528891f4f8
--- /dev/null
+++ b/mousetrap.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "WARNING: you must enable access to /dev/input with 'gpasswd -a username input' for thie program to work"
+ echo "Find your mouse ID with 'ls /dev/input/by-id' and run 'mousetrap -t (time in seconds) -d (your mouse ID)'"
+}