summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-03-01 00:04:56 +0000
committerMaxime “pep” Buquet2019-03-01 00:04:56 +0000
commit7bae2b675b2aee95846530c02ac0b31c66d1a193 (patch)
tree5fa7a9fd9de8d8312c66149c6a471fcd98afcc0d
parent7c73f5fd717ceecbbd3c12dbafc96fe00bc63024 (diff)
downloadaur-7bae2b675b2aee95846530c02ac0b31c66d1a193.tar.gz
Update for 0.14.1 release; plus misc changes
Following changes made to aur/movim-git. Now using tmpfiles.d. Also removed the jabber group. Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD49
-rw-r--r--movim.service4
-rw-r--r--sysuser.conf1
-rw-r--r--tmpfiles.conf11
5 files changed, 44 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a19a3f2c192..cff3eec01ada 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = movim
pkgdesc = Movim is a decentralized social network, written in PHP and HTML5 and based on the XMPP standard protocol.
- pkgver = v0.14.bbaa1e4f
+ pkgver = 0.14.1.97bb70d4d
pkgrel = 1
url = https://movim.eu
install = movim.install
@@ -10,22 +10,27 @@ pkgbase = movim
makedepends = composer
depends = php-gd
depends = php-imagick
- depends = php-zmq
optdepends = postgresql: to use the postgresql database backend
optdepends = php-pgsql: php bindings for postgresql
+ optdepends = php-sqlite: php bindings for sqlite
optdepends = mariadb: to use the mysql database backend
+ optdepends = sqlite3: to use the sqlite database backend
optdepends = nginx: reverse proxy
optdepends = apache: reverse proxy
optdepends = php-fpm: PHP FactCGI process manager
provides = movim
backup = etc/webapps/movim/db.inc.php
backup = etc/default/movim
- source = movim::git+https://github.com/movim/movim#tag=v0.14
+ source = movim::git+https://github.com/movim/movim#tag=0.14.1
source = movim.env
source = movim.service
+ source = sysuser.conf
+ source = tmpfiles.conf
sha256sums = SKIP
sha256sums = 5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306
- sha256sums = 793b85ca2080d92d9663af1750d0be9d1cbd20de9c828cb0ce0cc91ad5510f11
+ sha256sums = 813d580300ee5bb7f1f9603db2404f5af67fd02f49017708d4adb919d4422045
+ sha256sums = c8b569f1eafb97d8d03bbaabb9b4d6ed3415f922a05a52bd865942676368f4c5
+ sha256sums = e3cd2ceb71f4ef4689028313188def52aa19859e35aa8abcaa200495cd187935
pkgname = movim
diff --git a/PKGBUILD b/PKGBUILD
index 38f895ba1890..8faea1fa8b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
# Contributor: Guillaume Friloux <guillaume@friloux.me>
_pkgbase='movim'
-_tagname=v0.14
+_tagname=0.14.1
pkgname=movim
-pkgver=v0.14.bbaa1e4f
+pkgver=0.14.1.97bb70d4d
pkgrel=1
pkgdesc="Movim is a decentralized social network, written in PHP and HTML5 and based on the XMPP standard protocol."
arch=('any')
url='https://movim.eu'
license=('AGPL3')
provides=('movim')
-depends=('php-gd' 'php-imagick' 'php-zmq')
+depends=('php-gd' 'php-imagick')
optdepends=('postgresql: to use the postgresql database backend'
'php-pgsql: php bindings for postgresql'
+ 'php-sqlite: php bindings for sqlite'
'mariadb: to use the mysql database backend'
+ 'sqlite3: to use the sqlite database backend'
'nginx: reverse proxy'
'apache: reverse proxy'
'php-fpm: PHP FactCGI process manager')
makedepends=('git' 'composer')
-source=("$_pkgbase::git+https://github.com/movim/movim#tag=$_tagname"
+source=("$_pkgbase::git+https://github.com/movim/movim#tag=${_tagname}"
movim.env
- movim.service)
+ movim.service
+ sysuser.conf
+ tmpfiles.conf)
install=movim.install
backup=("etc/webapps/$_pkgbase/db.inc.php"
"etc/default/movim")
@@ -40,15 +44,14 @@ build() {
package() {
cd "$srcdir/$_pkgbase"
- install -m755 -d "$pkgdir/usr/share/webapps/$_pkgbase"
+ # Systemd files
+ install -m755 -d "$pkgdir/etc/default"
+ install -Dm640 "$srcdir/movim.env" "$pkgdir/etc/default/$_pkgbase"
+ install -Dm644 "$srcdir/movim.service" "$pkgdir/usr/lib/systemd/system/movim.service"
+ install -Dm644 "$srcdir/sysuser.conf" "$pkgdir/usr/lib/sysusers.d/movim.conf"
+ install -Dm644 "$srcdir/tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/movim.conf"
- # Cache
- install -m750 -d "$pkgdir/var/cache/webapps/$_pkgbase/cache"\
- "$pkgdir/var/cache/webapps/$_pkgbase/users"
- chown -R root:http "$pkgdir/var/cache/webapps/$_pkgbase"
- chmod -R u+rwX,g+rwX,o-rwx "$pkgdir/var/cache/webapps/$_pkgbase"
- # XXX: Symlinks created post_upgrade. Waiting for upstream to fix
- # https://github.com/movim/movim/issues/509.
+ install -m755 -d "$pkgdir/usr/share/webapps/$_pkgbase"
cp -r app database lib locales src themes vendor \
"$pkgdir/usr/share/webapps/$_pkgbase"
@@ -58,21 +61,11 @@ package() {
# Configuration file
install -m750 -d "$pkgdir/etc/webapps/$_pkgbase"
- install -Dm750 config/db.example.inc.php "$pkgdir/etc/webapps/$_pkgbase/db.inc.php"
- chown -R root:http "$pkgdir/etc/webapps/$_pkgbase"
- chmod -R u+rwX,g+rwX,o-rwx "$pkgdir/etc/webapps/$_pkgbase"
- ln -s "/etc/webapps/$_pkgbase" "$pkgdir/usr/share/webapps/$_pkgbase/config"
-
- # Log files
- install -m770 -d "$pkgdir/var/log/webapps/$_pkgbase"
- chown -R root:http "$pkgdir/var/log/webapps/$_pkgbase"
- ln -s "/var/log/webapps/$_pkgbase" "$pkgdir/usr/share/webapps/$_pkgbase/log"
-
- # Systemd unit file
- install -m755 -d "$pkgdir/etc/default"
- install -g http -Dm640 "$srcdir/movim.env" "$pkgdir/etc/default/$_pkgbase"
- install -Dm644 "$srcdir/movim.service" "$pkgdir/usr/lib/systemd/system/movim.service"
+ install -Dm640 config/db.example.inc.php "$pkgdir/etc/webapps/$_pkgbase/db.inc.php"
}
+
sha256sums=('SKIP'
'5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306'
- '793b85ca2080d92d9663af1750d0be9d1cbd20de9c828cb0ce0cc91ad5510f11')
+ '813d580300ee5bb7f1f9603db2404f5af67fd02f49017708d4adb919d4422045'
+ 'c8b569f1eafb97d8d03bbaabb9b4d6ed3415f922a05a52bd865942676368f4c5'
+ 'e3cd2ceb71f4ef4689028313188def52aa19859e35aa8abcaa200495cd187935')
diff --git a/movim.service b/movim.service
index 30a66748e365..3bf012ab8763 100644
--- a/movim.service
+++ b/movim.service
@@ -3,10 +3,10 @@ Description=Movim Daemon
After=network.target
[Service]
-Group=http
+User=movim
WorkingDirectory=/usr/share/webapps/movim
EnvironmentFile=/etc/default/movim
-ExecStartPre=/usr/bin/php mud.php db --set
+ExecStartPre=/usr/bin/php vendor/bin/phinx migrate
ExecStart=/usr/bin/php daemon.php start --url=${MOVIM_URL} --port=${MOVIM_PORT} --interface=${MOVIM_INTERFACE}
Restart=always
diff --git a/sysuser.conf b/sysuser.conf
new file mode 100644
index 000000000000..ffe03b0eb436
--- /dev/null
+++ b/sysuser.conf
@@ -0,0 +1 @@
+u movim - "Movim XMPP Client" /var/lib/webapps/movim
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..82db5a178e83
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1,11 @@
+d /etc/webapps/movim 0750 root movim - -
+f /etc/webapps/movim/db.inc.php 0640 root movim - -
+L /usr/share/webapps/movim/config - - - - /etc/webapps/movim
+d %C/webapps/movim 0751 movim root - -
+d %C/webapps/movim/cache 0751 movim root - -
+d %C/webapps/movim/users 0750 movim root - -
+L /usr/share/webapps/movim/users - - - - %C/webapps/movim/users
+L /usr/share/webapps/movim/cache - - - - %C/webapps/movim/cache
+d %L/webapps/movim 0750 movim root - -
+L /usr/share/webapps/movim/log - - - - %L/webapps/movim
+d %S/webapps/movim 0750 movim root - -