summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2018-12-20 11:48:10 +0000
committerMaxime “pep” Buquet2018-12-20 11:48:10 +0000
commit53c0d76d1c49e6885aad29deeeb5d815fde15cdf (patch)
treed7c7dd822d3399133b0e2421d26bee2b237361d5
parent0229222dc9417a22af8c9bf66ca1ab6189f9497e (diff)
downloadaur-53c0d76d1c49e6885aad29deeeb5d815fde15cdf.tar.gz
Create movim user; Use in service file
Signed-off-by: Maxime “pep” Buquet <archlinux@bouah.net>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--movim.service2
-rw-r--r--sysuser.conf3
4 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe1ba1b5343f..d19d61573624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,9 +25,11 @@ pkgbase = movim-git
source = movim::git+https://github.com/movim/movim
source = movim.env
source = movim.service
+ source = sysuser.conf
sha256sums = SKIP
sha256sums = 5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306
- sha256sums = b348b86ccfe56b104ada9134672bf77054b148b2a2eb9f704be429905fc3d834
+ sha256sums = 813d580300ee5bb7f1f9603db2404f5af67fd02f49017708d4adb919d4422045
+ sha256sums = a0aae072d9ee93d270fec602a3fe65bfc63e0de8814f3af6ddebb8ed223391fc
pkgname = movim-git
diff --git a/PKGBUILD b/PKGBUILD
index 73ada376f226..895eef3508e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,8 @@ optdepends=('postgresql: to use the postgresql database backend'
makedepends=('git' 'composer')
source=("$_pkgbase::git+https://github.com/movim/movim"
movim.env
- movim.service)
+ movim.service
+ sysuser.conf)
install=movim.install
backup=("etc/webapps/$_pkgbase/db.inc.php"
"etc/default/movim")
@@ -69,12 +70,14 @@ package() {
chown -R root:http "$pkgdir/var/log/webapps/$_pkgbase"
ln -s "/var/log/webapps/$_pkgbase" "$pkgdir/usr/share/webapps/$_pkgbase/log"
- # Systemd unit file
+ # Systemd files
install -m755 -d "$pkgdir/etc/default"
install -g http -Dm640 "$srcdir/movim.env" "$pkgdir/etc/default/$_pkgbase"
install -Dm644 "$srcdir/movim.service" "$pkgdir/usr/lib/systemd/system/movim.service"
+ install -Dm644 "$srcdir/sysuser.conf" "$pkgdir/usr/lib/sysuser.d/movim.conf"
}
sha256sums=('SKIP'
'5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306'
- 'b348b86ccfe56b104ada9134672bf77054b148b2a2eb9f704be429905fc3d834')
+ '813d580300ee5bb7f1f9603db2404f5af67fd02f49017708d4adb919d4422045'
+ 'a0aae072d9ee93d270fec602a3fe65bfc63e0de8814f3af6ddebb8ed223391fc')
diff --git a/movim.service b/movim.service
index c3c4f5e76be5..3bf012ab8763 100644
--- a/movim.service
+++ b/movim.service
@@ -3,7 +3,7 @@ Description=Movim Daemon
After=network.target
[Service]
-Group=http
+User=movim
WorkingDirectory=/usr/share/webapps/movim
EnvironmentFile=/etc/default/movim
ExecStartPre=/usr/bin/php vendor/bin/phinx migrate
diff --git a/sysuser.conf b/sysuser.conf
new file mode 100644
index 000000000000..79e35a774f9e
--- /dev/null
+++ b/sysuser.conf
@@ -0,0 +1,3 @@
+g jabber 17 - -
+u movim - "Movim XMPP Client" /usr/share/webapp/movim
+m movim jabber