summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Buquet2018-06-02 05:56:11 +0900
committerMaxime Buquet2018-06-02 05:56:11 +0900
commit9b5c72913b2cbfac60e211a3fa4b62b5210fade6 (patch)
tree08ee64db2b5b613322adaaf1d482702fa87479f7
parentbb7841f398b1bdecde5de89a7b9e1828495da269 (diff)
downloadaur-9b5c72913b2cbfac60e211a3fa4b62b5210fade6.tar.gz
Update for new ORM system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--movim.service2
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 785de3cd9b22..910de66f79a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = movim-git
pkgdesc = Movim is a decentralized social network, written in PHP and HTML5 and based on the XMPP standard protocol.
- pkgver = r6336.5fd158bd
+ pkgver = r6815.8fba1ad6
pkgrel = 1
url = https://movim.eu
install = movim.install
@@ -26,7 +26,7 @@ pkgbase = movim-git
source = movim.service
sha256sums = SKIP
sha256sums = 5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306
- sha256sums = 793b85ca2080d92d9663af1750d0be9d1cbd20de9c828cb0ce0cc91ad5510f11
+ sha256sums = b348b86ccfe56b104ada9134672bf77054b148b2a2eb9f704be429905fc3d834
pkgname = movim-git
diff --git a/PKGBUILD b/PKGBUILD
index b8e634d33bed..33123d5a94b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase='movim'
pkgname=movim-git
-pkgver=r6336.5fd158bd
+pkgver=r6815.8fba1ad6
pkgrel=1
pkgdesc="Movim is a decentralized social network, written in PHP and HTML5 and based on the XMPP standard protocol."
arch=('any')
@@ -23,9 +23,6 @@ source=("$_pkgbase::git+https://github.com/movim/movim"
movim.env
movim.service)
install=movim.install
-sha256sums=('SKIP'
- '5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306'
- '793b85ca2080d92d9663af1750d0be9d1cbd20de9c828cb0ce0cc91ad5510f11')
backup=("etc/webapps/$_pkgbase/db.inc.php"
"etc/default/movim")
@@ -53,9 +50,10 @@ package() {
# XXX: Symlinks created post_upgrade. Waiting for upstream to fix
# https://github.com/movim/movim/issues/509.
- cp -r app lib locales src themes vendor "$pkgdir/usr/share/webapps/$_pkgbase"
+ cp -r app database lib locales src themes vendor \
+ "$pkgdir/usr/share/webapps/$_pkgbase"
install -Dm644 VERSION CHANGELOG.md INSTALL.md README.md index.php \
- linker.php manifest.webapp "$pkgdir/usr/share/webapps/$_pkgbase"
+ linker.php phinx.php "$pkgdir/usr/share/webapps/$_pkgbase"
install -Dm755 daemon.php "$pkgdir/usr/share/webapps/$_pkgbase"
# Configuration file
@@ -75,3 +73,7 @@ package() {
install -g http -Dm640 "$srcdir/movim.env" "$pkgdir/etc/default/$_pkgbase"
install -Dm644 "$srcdir/movim.service" "$pkgdir/usr/lib/systemd/system/movim.service"
}
+
+sha256sums=('SKIP'
+ '5dfff91dd4a54f3d3713530e204370a96d37898b670a61123d8cad42f92da306'
+ 'b348b86ccfe56b104ada9134672bf77054b148b2a2eb9f704be429905fc3d834')
diff --git a/movim.service b/movim.service
index 30a66748e365..c3c4f5e76be5 100644
--- a/movim.service
+++ b/movim.service
@@ -6,7 +6,7 @@ After=network.target
Group=http
WorkingDirectory=/usr/share/webapps/movim
EnvironmentFile=/etc/default/movim
-ExecStartPre=/usr/bin/php mud.php db --set
+ExecStartPre=/usr/bin/php vendor/bin/phinx migrate
ExecStart=/usr/bin/php daemon.php start --url=${MOVIM_URL} --port=${MOVIM_PORT} --interface=${MOVIM_INTERFACE}
Restart=always