summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2015-08-27 01:01:17 +0200
committerTom Willemse2015-08-27 01:01:17 +0200
commitd88e8f816f9226bf7277c2d551e270edf9ec3b42 (patch)
tree26450ba8552cc99d8ec864b1b8c6088d53b1cd10
downloadaur-d88e8f816f9226bf7277c2d551e270edf9ec3b42.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD61
-rw-r--r--chicken.install15
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb5bb4610eaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = mowedline
+ pkgdesc = an X status bar program
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = http://retroj.net/mowedline
+ arch = x86_64
+ license = GPL3
+ depends = chicken
+ depends = chicken-coops
+ depends = chicken-dbus>=0.92
+ depends = chicken-filepath
+ depends = chicken-imperative-command-line-a>=0.4
+ depends = chicken-list-utils
+ depends = chicken-mailbox
+ depends = chicken-matchable
+ depends = chicken-miscmacros
+ depends = chicken-xft
+ depends = chicken-xlib
+ depends = chicken-xtypes
+ depends = chicken-coops-utils
+ depends = chicken-xlib-utils
+ provides = mowedline
+ conflicts = mowedline
+ source = mowedline-0.2.8.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=mowedline&version=0.2.8
+ source = mowedline-0.2.8.html::http://wiki.call-cc.org/eggref/4/mowedline.html
+ md5sums = e5964503fc3202f9f3978176eb4a6efe
+ md5sums = fbb161cb902a5ea3d77d8268e2c22a87
+
+pkgname = mowedline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..208196e282a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Tom Willemse <tom@ryuslash.org>
+
+_gitname='mowedline'
+
+pkgname=mowedline
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="an X status bar program"
+depends=('chicken' 'chicken-coops' 'chicken-dbus>=0.92'
+ 'chicken-filepath' 'chicken-imperative-command-line-a>=0.4'
+ 'chicken-list-utils' 'chicken-mailbox' 'chicken-matchable'
+ 'chicken-miscmacros' 'chicken-xft' 'chicken-xlib'
+ 'chicken-xtypes' 'chicken-coops-utils' 'chicken-xlib-utils')
+conflicts=('mowedline')
+provides=('mowedline')
+arch=('x86_64')
+url='http://retroj.net/mowedline'
+license=('GPL3')
+install='chicken.install'
+md5sums=('e5964503fc3202f9f3978176eb4a6efe'
+ 'fbb161cb902a5ea3d77d8268e2c22a87')
+
+# template start; name=chicken-module; version=2;
+_name=${pkgname#chicken-}
+
+source=("${pkgname}-${pkgver}.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=${_name}&version=${pkgver}"
+ "${pkgname}-${pkgver}.html::http://wiki.call-cc.org/eggref/4/${_name}.html")
+
+build() {
+ # unchunk the blob that was downloaded from henrietta
+ cd "$srcdir"
+ mkdir -p "${_name}-${pkgver}"
+ cat "${pkgname}-${pkgver}.chunked" | while :; do
+ while read -r bar ver endbar fname len; do
+ [[ -n "$ver" ]] && break
+ done
+ [[ "$endbar" = "|#" ]] || fname="$ver" len="$endbar"
+ [[ -z "$fname" ]] && break
+ fname="${fname:1:${#fname}-2}" # delete quotes around fname
+ if [[ "${fname: -1}" == / ]]; then
+ mkdir -p "${_name}-${pkgver}/${fname}"
+ elif [[ "$len" -eq 0 ]]; then
+ touch "${_name}-${pkgver}/${fname}"
+ else
+ dd iflag=fullblock of="${_name}-${pkgver}/${fname}" ibs="$len" count=1 2>/dev/null
+ fi
+ done
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ cp "../${pkgname}-${pkgver}.html" "${_name}.html"
+
+
+ mkdir -p "${pkgdir}/usr/lib/chicken/5" "${pkgdir}/usr/share/chicken/${_name}"
+
+ chicken-install -p "${pkgdir}/usr"
+
+ install -Dm644 "${_name}.html" "${pkgdir}/usr/share/doc/${pkgname}/${_name}.html"
+}
+# template end;
diff --git a/chicken.install b/chicken.install
new file mode 100644
index 000000000000..2022006b327d
--- /dev/null
+++ b/chicken.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ chicken-install -u
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}