summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2023-12-18 22:34:49 -0500
committerChris Severance2023-12-18 22:34:49 -0500
commit4bf5df5ed20149bd10d78fb62b43b4cbb78be8ad (patch)
treef7d32e9d2e86d2883be67c475c5b5991db91940f
parent00c4511f418b9e6073c034710c6752fc4048e1c9 (diff)
downloadaur-4bf5df5ed20149bd10d78fb62b43b4cbb78be8ad.tar.gz
autu: Update to 1.2.13-7
-rw-r--r--.SRCINFO9
-rw-r--r--0005-kernel-5.13-dropped-tty_check_change.patch2
-rw-r--r--0011-kernel-6.6-struct-tty_operations-size_t.patch20
-rw-r--r--PKGBUILD33
4 files changed, 48 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d956070ba6d..a759ecafcadf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moxa-uport16x0
pkgdesc = kernel module driver for Moxa multi port USB serial 1250 1410 1450 1610 1650 RS-232 422 485
pkgver = 1.2.13
- pkgrel = 6
+ pkgrel = 7
url = https://www.moxa.com/product/UPort_1610-8_1650-8.htm
install = moxa-uport16x0-install.sh
arch = i686
@@ -28,23 +28,26 @@ pkgbase = moxa-uport16x0
source = 0008-kernel-5.15-alloc_tty_driver-put_tty_driver.patch
source = 0009-kernel-6.1-user_termios_to_kernel_termios-copy_from_user.patch
source = 0010-kernel-6.0-set_termios-const-ktermios.patch
+ source = 0011-kernel-6.6-struct-tty_operations-size_t.patch
md5sums = 17a240340a322b3da2e07fc929950288
md5sums = 9ec720fdaaccc41648ffb6d58c45c64e
md5sums = 13cc25e1625f1dc8456aaf703efbe816
- md5sums = c06ffb879ec71eb19a74eb90839f4d91
+ md5sums = dcf3339ea666cb7ed48e461ba07ebf48
md5sums = b20646163937da295547dc8bf4bbaccf
md5sums = 4d1d2a36a1707e93f83db3d75e221c6f
md5sums = 637fca359414559c4e5029775da82d85
md5sums = a9604e54d37a29590492c92311b18400
md5sums = a9d2f5eb65ed26436692cfc37e607e66
+ md5sums = 4d1271d2313ab713a006a2443b8284bd
sha256sums = aed6f9a1bb6e88a22b520dc6cbbb6624accea080dcaca727c0fab031868228b6
sha256sums = f753e48ea68282288bd53f045c88bd61e39a4c6cf691544953c6929888183370
sha256sums = 151a7c84d3815814d45cebd6d58427c27a2b3c6e06c1209d984738e94fea90d8
- sha256sums = 4840cccfcd432b7b4f861b5b556c0445f4cd93d277c6cb0045eeebaf92190c4e
+ sha256sums = 5db4c06da7293de1a4070fa2313cdff27cc5c4b39832f7110ca52692ed16419b
sha256sums = 045a3957b540ff8a9f9e401c343683a794837bda4e047759564df6ce2e8912a4
sha256sums = 1b0bea590d671fc52b2e5231062ebdc07984e594e07ecdee4883fddbe78b4fa3
sha256sums = f16425c12383498687fd3b38e782fe54c399e0962e437d49c417f86b0d99b563
sha256sums = c765e7dfdcd684d29dc5dc7595733addb95eb4264100d73ed1d541cd4329dde7
sha256sums = fc62764f2be15e2906f7f28a80b818643257ea523eacc5aa18a444a1af4e178c
+ sha256sums = 17cc56a95f1a84aa00024da223a8f416a4da3d9b8f68768f460c530719e831c7
pkgname = moxa-uport16x0
diff --git a/0005-kernel-5.13-dropped-tty_check_change.patch b/0005-kernel-5.13-dropped-tty_check_change.patch
index 491f41ff08f0..83d1172976c2 100644
--- a/0005-kernel-5.13-dropped-tty_check_change.patch
+++ b/0005-kernel-5.13-dropped-tty_check_change.patch
@@ -6,7 +6,7 @@
return;
}
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5,13,0))
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5,10,180))
+int tty_check_change(struct tty_struct *tty);
+#endif
+
diff --git a/0011-kernel-6.6-struct-tty_operations-size_t.patch b/0011-kernel-6.6-struct-tty_operations-size_t.patch
new file mode 100644
index 000000000000..037ff69f14c1
--- /dev/null
+++ b/0011-kernel-6.6-struct-tty_operations-size_t.patch
@@ -0,0 +1,20 @@
+diff -pNaru5 a/driver/mxusbserial/mxusb-serial.c b/driver/mxusbserial/mxusb-serial.c
+--- a/driver/mxusbserial/mxusb-serial.c 2023-12-18 22:26:56.544609750 -0500
++++ b/driver/mxusbserial/mxusb-serial.c 2023-12-18 22:27:01.967913954 -0500
+@@ -633,12 +633,16 @@ static void serial_close(struct tty_stru
+
+ }
+ #endif
+
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,9))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(6,6,0))
+ static int serial_write (struct tty_struct * tty, const unsigned char *buf, int count)
+ #else
++static ssize_t serial_write (struct tty_struct * tty, const u8 *buf, size_t count)
++#endif
++#else
+ static int serial_write (struct tty_struct * tty, int from_user, const unsigned char *buf, int count)
+ #endif
+ {
+ struct usb_serial_port *port = tty->driver_data;
+ int retval = -EINVAL;
diff --git a/PKGBUILD b/PKGBUILD
index 89c7dd0b7353..ab098eca9fe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,8 @@
_opt_DKMS=1 # This can be toggled between installs
+#export KERNELRELEASE="$(basename $(dirname /usr/lib/modules/5.10.*/modules.alias))"
+
# ls -l /dev/ttyMXUSB[0-9]*
# lsmod | grep mx
# setserial -g /dev/ttyMXUSB*
@@ -44,7 +46,7 @@ _servicename="${pkgname}-settings"
#pkgver='1.2'; _build='12071314'
#pkgver='1.2.9'; _build='14103017'
pkgver='1.2.13'; _build='18030617'
-pkgrel='6'
+pkgrel='7'
pkgdesc='kernel module driver for Moxa multi port USB serial 1250 1410 1450 1610 1650 RS-232 422 485'
_servicedesc='Moxa UPort persistent settings'
arch=('i686' 'x86_64')
@@ -72,25 +74,28 @@ source=(
'0008-kernel-5.15-alloc_tty_driver-put_tty_driver.patch'
'0009-kernel-6.1-user_termios_to_kernel_termios-copy_from_user.patch'
'0010-kernel-6.0-set_termios-const-ktermios.patch'
+ '0011-kernel-6.6-struct-tty_operations-size_t.patch'
)
md5sums=('17a240340a322b3da2e07fc929950288'
'9ec720fdaaccc41648ffb6d58c45c64e'
'13cc25e1625f1dc8456aaf703efbe816'
- 'c06ffb879ec71eb19a74eb90839f4d91'
+ 'dcf3339ea666cb7ed48e461ba07ebf48'
'b20646163937da295547dc8bf4bbaccf'
'4d1d2a36a1707e93f83db3d75e221c6f'
'637fca359414559c4e5029775da82d85'
'a9604e54d37a29590492c92311b18400'
- 'a9d2f5eb65ed26436692cfc37e607e66')
+ 'a9d2f5eb65ed26436692cfc37e607e66'
+ '4d1271d2313ab713a006a2443b8284bd')
sha256sums=('aed6f9a1bb6e88a22b520dc6cbbb6624accea080dcaca727c0fab031868228b6'
'f753e48ea68282288bd53f045c88bd61e39a4c6cf691544953c6929888183370'
'151a7c84d3815814d45cebd6d58427c27a2b3c6e06c1209d984738e94fea90d8'
- '4840cccfcd432b7b4f861b5b556c0445f4cd93d277c6cb0045eeebaf92190c4e'
+ '5db4c06da7293de1a4070fa2313cdff27cc5c4b39832f7110ca52692ed16419b'
'045a3957b540ff8a9f9e401c343683a794837bda4e047759564df6ce2e8912a4'
'1b0bea590d671fc52b2e5231062ebdc07984e594e07ecdee4883fddbe78b4fa3'
'f16425c12383498687fd3b38e782fe54c399e0962e437d49c417f86b0d99b563'
'c765e7dfdcd684d29dc5dc7595733addb95eb4264100d73ed1d541cd4329dde7'
- 'fc62764f2be15e2906f7f28a80b818643257ea523eacc5aa18a444a1af4e178c')
+ 'fc62764f2be15e2906f7f28a80b818643257ea523eacc5aa18a444a1af4e178c'
+ '17cc56a95f1a84aa00024da223a8f416a4da3d9b8f68768f460c530719e831c7')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -206,6 +211,10 @@ prepare() {
# diff -pNaru5 'a' 'b' > '0010-kernel-6.0-set_termios-const-ktermios.patch'
patch -Nup1 -i "${srcdir}/0010-kernel-6.0-set_termios-const-ktermios.patch"
+ #cd '..'; cp -pr "${_srcdir}" 'a'; ln -s "${_srcdir}" 'b'; false
+ # diff -pNaru5 'a' 'b' > '0011-kernel-6.6-struct-tty_operations-size_t.patch'
+ patch -Nup1 -i "${srcdir}/0011-kernel-6.6-struct-tty_operations-size_t.patch"
+
# Fix umbrella Makefile
sed -e '# Disable silent' \
-e '/make / s:\s\+-s::g' \
@@ -216,6 +225,13 @@ prepare() {
#cp -p driver/Makefile{,.Arch}
sed -e '# Remove pesky blank line. n messes up the positioning so we do it separately' \
-e '/^modules:/ {n; d}' \
+ -e '# No DKMS instructions say to do this but it works and keeps the MAKE line real simple' \
+ -e 's:shell uname -r:KERNELRELEASE:g' \
+ -e '# DKMS sets KERNELRELEASE which accidentally launches phase 2 of this Makefile' \
+ -e '# Fix by changing the detection var.' \
+ -e '# SUBDIRS makes more sense to me because I can see it in the Makefile!' \
+ -e 's:^ifneq (\$(KERNELRELEASE),):ifneq (\$(SUBDIRS),):g' \
+ -e '1i KERNELRELEASE?=$(shell uname -r)' \
-i 'driver/Makefile'
# Make package compatible
sed -e '# Fix path' \
@@ -413,13 +429,6 @@ DEST_MODULE_LOCATION[1]="${_driverfd}"
EOF
) "${_dkms}/dkms.conf"
cp -pr 'driver/' "${_dkms}/"
- sed -e '# No DKMS instructions say to do this but it works and keeps the MAKE line real simple' \
- -e 's:shell uname -r:KERNELRELEASE:g' \
- -e '# DKMS sets KERNELRELEASE which accidentally launches phase 2 of this Makefile' \
- -e '# Fix by changing the detection var.' \
- -e '# SUBDIRS makes more sense to me because I can see it in the Makefile!' \
- -e 's:^ifneq (\$(KERNELRELEASE),):ifneq (\$(SUBDIRS),):g' \
- -i "${_dkms}/driver/Makefile"
make -s -C "${_dkms}/driver/" clean KERNELRELEASE="$(uname -r)"
fi
set +u