summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChanathip Srithanrat2018-05-25 23:18:39 +0700
committerChanathip Srithanrat2018-05-25 23:18:39 +0700
commit2f6bfae5500c4d0661d2255b544fe9c84568faa2 (patch)
tree72e1d2122ab38aba0799f740ee6940adb3340b40
downloadaur-2f6bfae5500c4d0661d2255b544fe9c84568faa2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..154f35bbedc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mozart2-bin
+ pkgdesc = Runtime and development environment of Oz
+ pkgver = 2.0.0_alpha.0
+ pkgrel = 1
+ url = https://mozart.github.io/
+ arch = x86_64
+ license = BSD
+ depends = tk
+ depends = emacs
+ conflicts = mozart2
+ conflicts = mozart2-compiler
+ source = mozart2-bin-2.0.0_alpha.0.rpm::https://sourceforge.net/projects/mozart-oz/files/v2.0.0-alpha.0/mozart2-2.0.0-alpha.0+build.4140.005f700-x86_64-fc22.rpm/download
+ source = https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt
+ md5sums = 33ce35da79de268ad987b4150d0eb82a
+ md5sums = 761f3c1b5b9987bc87abc4ca8e6440fa
+
+pkgname = mozart2-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69f7aac7f84b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Chanathip Srithanrat <axesd9@gmail.com>
+
+pkgname=mozart2-bin
+pkgver=2.0.0_alpha.0
+pkgrel=1
+pkgdesc='Runtime and development environment of Oz'
+arch=('x86_64')
+url='https://mozart.github.io/'
+license=('BSD')
+depends=('tk' 'emacs')
+conflicts=('mozart2' 'mozart2-compiler')
+source=("$pkgname-$pkgver.rpm::https://sourceforge.net/projects/mozart-oz/files/v2.0.0-alpha.0/mozart2-${pkgver/_/-}+build.4140.005f700-$CARCH-fc22.rpm/download"
+ "https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt")
+md5sums=('33ce35da79de268ad987b4150d0eb82a'
+ '761f3c1b5b9987bc87abc4ca8e6440fa')
+
+package() {
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ cp -R usr $pkgdir
+}