summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Maudoux2016-09-22 10:06:38 +0200
committerGuillaume Maudoux2016-09-22 10:06:38 +0200
commit9ac74343d96bc2779090ac1aebaf9538d863ee8e (patch)
treed64b6a37526b15d54112c2e5091fceed6d3b0dda
parent759ad73fad08d5088a5534a8a57198a9431f3e32 (diff)
downloadaur-9ac74343d96bc2779090ac1aebaf9538d863ee8e.tar.gz
Fix for upstream modified build system
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f417587d9cf4..858b0fde93e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 25 07:18:45 UTC 2016
+# Thu Sep 22 08:04:41 UTC 2016
pkgbase = mozart2-git
pkgdesc = The Mozart Programming System version 2
- pkgver = v2.0.0.alpha.0.4166.g224deca
+ pkgver = v2.0.0.alpha.0.4180.g7bdb820
pkgrel = 1
url = https://github.com/mozart/mozart2
install = mozart2-git.install
@@ -30,6 +30,8 @@ pkgbase = mozart2-git
conflicts = mozart2-bin
source = mozart2-git::git+https://github.com/mozart/mozart2
source = git+https://github.com/mozart/mozart2-stdlib
+ source = git+https://github.com/google/googletest
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b8fb3f7c3160..7aedda69df72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Maudoux <layus DOT on @AT@ gmail DOT com>
pkgname=mozart2-git
-pkgver=v2.0.0.alpha.0.4166.g224deca
+pkgver=v2.0.0.alpha.0.4180.g7bdb820
pkgrel=1
pkgdesc="The Mozart Programming System version 2"
arch=('i686' 'x86_64')
@@ -16,11 +16,9 @@ install="${pkgname}.install"
source=(
"$pkgname::git+https://github.com/mozart/mozart2"
'git+https://github.com/mozart/mozart2-stdlib'
+ 'git+https://github.com/google/googletest'
)
-sha256sums=(
- 'SKIP'
- 'SKIP'
-)
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$pkgname"
@@ -32,6 +30,7 @@ prepare() {
git submodule init
git config submodule.stdlib.url $srcdir/mozart2-stdlib
+ git config submodule.gtest.url $srcdir/googletest
git submodule update
# Add required libraries to executable.
@@ -57,11 +56,6 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr/ \
-DMOZART_BOOST_USE_STATIC_LIBS=OFF \
- -DGTEST_BUILD_DIR=/usr/lib/ \
- -DGTEST_SRC_DIR=/usr/include/gtest/ \
- -DLLVM_BUILD_DIR=/usr/ \
- -DLLVM_SRC_DIR=/usr/ \
- -DCMAKE_CXX_FLAGS=-Wno-braced-scalar-init \
.
make #VERBOSE=1