summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorponsfoot2018-03-04 14:57:03 +0900
committerponsfoot2018-03-04 14:57:03 +0900
commitd4b44beb4e4f736801a4a9bfa1e7b54c241c72c7 (patch)
tree64bfb03dfb685951827fc093ef5aadd82b7cba5e
parenteb107786133c8310dbf44c34410773e0f4304d78 (diff)
downloadaur-d4b44beb4e4f736801a4a9bfa1e7b54c241c72c7.tar.gz
Upstream update
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 23 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb5c43941c28..cd4351b414b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# 日 4月 16 10:04:51 UTC 2017
+# 日 3月 4 05:57:03 UTC 2018
pkgbase = mozc
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
- pkgver = 2.20.2673.102
- pkgrel = 2
+ pkgver = 2.23.2815.102
+ pkgrel = 1
url = http://code.google.com/p/mozc/
arch = i686
arch = x86_64
@@ -18,12 +18,12 @@ pkgbase = mozc
depends = qt5-base
depends = ibus>=1.4.1
depends = zinnia
- source = mozc::git+https://github.com/google/mozc.git#commit=280e38fe3d9db4df52f0713acf2ca65898cd697a
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201703.zip
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201703.zip
+ source = mozc::git+https://github.com/google/mozc.git#commit=afb03ddfe72dde4cf2409863a3bfea160f7a66d8
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201802.zip
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201802.zip
sha1sums = SKIP
- sha1sums = 238b182e553ade5a92cb6502f5f81e2ca34ecc26
- sha1sums = d2ba37f4bd5d20c85c7e732a4a1d50704d384319
+ sha1sums = eb7fc1320a0ddcb5dd10d086211c5ae834cad73a
+ sha1sums = 260b382b3d8fa2743184ed851e78616feafb6dc3
pkgname = mozc
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
@@ -44,7 +44,7 @@ pkgname = emacs-mozc
arch = i686
arch = x86_64
groups = mozc-im
- depends = mozc=2.20.2673.102
+ depends = mozc=2.23.2815.102
depends = emacs
conflicts = emacs-mozc-bin
replaces = emacs-mozc-bin
@@ -54,6 +54,6 @@ pkgname = ibus-mozc
arch = i686
arch = x86_64
groups = mozc-im
- depends = mozc=2.20.2673.102
+ depends = mozc=2.23.2815.102
depends = ibus>=1.4.1
diff --git a/PKGBUILD b/PKGBUILD
index 9e1c15677c52..ae2b8315cd9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ponsfoot <cabezon dot hashimoto at gmail dot com>
## If you will be using mozc.el on Emacs, uncomment below.
-_emacs_mozc="yes"
+#_emacs_mozc="yes"
## If you will not be using ibus (only use uim), comment out below.
_ibus_mozc="yes"
@@ -11,8 +11,8 @@ _ibus_mozc="yes"
_zipcode="yes"
## Mozc compile option
-#_bldtype=Release
-_bldtype=Debug
+_bldtype=Release
+#_bldtype=Debug
#*************************************************************
# Upstreams:
@@ -27,14 +27,14 @@ _bldtype=Debug
# http://zipcloud.ibsnet.co.jp/
#*************************************************************
-_zipcoderel=201801
-_mozcrev=280e38fe3d9db4df52f0713acf2ca65898cd697a
+_zipcoderel=201802
+_mozcrev=afb03ddfe72dde4cf2409863a3bfea160f7a66d8
pkgbase=mozc
pkgname=mozc
true && pkgname=('mozc')
-pkgver=2.20.2673.102
-pkgrel=2
+pkgver=2.23.2815.102
+pkgrel=1
arch=('i686' 'x86_64')
url="http://code.google.com/p/mozc/"
license=('BSD' 'custom')
@@ -46,8 +46,8 @@ source=(
http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-${_zipcoderel}.zip
)
sha1sums=('SKIP'
- '8226fde66360ef99127e2e8ce8df41ff1452f938'
- 'a4d6dc99c9daf55b4bd359fdf967c2c2792ad5d5')
+ 'eb7fc1320a0ddcb5dd10d086211c5ae834cad73a'
+ '260b382b3d8fa2743184ed851e78616feafb6dc3')
if [[ "$_emacs_mozc" == "yes" ]]; then
@@ -75,9 +75,6 @@ prepare() {
cd "${srcdir}/${pkgbase}/src/"
- # Extract liccense part of mozc
- head -n 29 server/mozc_server.cc > LICENSE
-
# Generate zip code dictionary seed
if [[ "$_zipcode" == "yes" ]]; then
msg "Generating zip code dict seed..."
@@ -135,12 +132,12 @@ package_mozc() {
conflicts=('mozc-server' 'mozc-utils-gui')
optdepends=('tegaki-models-zinnia-japanese: hand-writing recognition support')
- cd "${srcdir}/${pkgbase}/src"
- install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
- install -m 755 out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"
+ cd "${srcdir}/${pkgbase}/"
+ install -D -m 755 src/out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
+ install -m 755 src/out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"
install -d "${pkgdir}/usr/share/licenses/mozc/"
- install -m 644 LICENSE data/installer/*.html "${pkgdir}/usr/share/licenses/mozc/"
+ install -m 644 LICENSE src/data/installer/*.html "${pkgdir}/usr/share/licenses/mozc/"
}
package_ibus-mozc() {