summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato HASHIMOTO2016-03-09 21:29:10 +0900
committerMasato HASHIMOTO2016-03-09 21:29:10 +0900
commit0ff71b130902928626811a0cd0e564bc3781c7a3 (patch)
tree575945efefe2c77c66d04592e08652f62e30a9d2
parent2e924fa90da819252829deddf5fabb1a4d972801 (diff)
downloadaur-0ff71b130902928626811a0cd0e564bc3781c7a3.tar.gz
utdic: upstream update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rwxr-xr-xmod-generate-mozc-ut.sh12
3 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23fb6002f68e..28d4c6f36fb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# 木 3月 3 12:55:47 UTC 2016
+# 水 3月 9 12:29:10 UTC 2016
pkgbase = mozc-ut
pkgdesc = Mozc the Japanese Input Method with Mozc UT Dictionary (additional dictionary) and uim-mozc (optional)
- pkgver = 2.17.2313.102.20160125
- pkgrel = 2
+ pkgver = 2.17.2313.102.20160303
+ pkgrel = 1
url = http://www.geocities.jp/ep3797/mozc_01.html
arch = i686
arch = x86_64
@@ -20,19 +20,19 @@ pkgbase = mozc-ut
depends = qt4
depends = zinnia
source = mozc::git+https://github.com/google/mozc.git#commit=2628af6995dbbbb9ccdb52d1160db1dbd5ed3bae
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/mozcdic-ut-20160125.tar.bz2
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/edict-20160125.gz
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/mozcdic-ut-20160303.tar.bz2
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/edict-20160303.gz
source = EDICT_license.html
source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201602.zip
source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201602.zip
source = mod-generate-mozc-ut.sh
sha1sums = SKIP
- sha1sums = c0e7d8e9d2a3dcc41effda4901f5142820565bf5
- sha1sums = 701737f457cd0a1832ff5e6ed961cf1d6317d5b7
+ sha1sums = 4db23b05c9a7d6a6fbc57f5714f2ce58b12d582f
+ sha1sums = a56267cdf87b5ea48c378107da180f45b7beb46a
sha1sums = e0ba18e67c1be8e3cfb8ecb30760597b215da255
sha1sums = 5cc2c2811e2a57ebaf671d09d727a86009f7f846
sha1sums = 4ba7faa2ebecb4ad52e05d92d7d18abae327a4fc
- sha1sums = 3b525b6802251c07d8cb3f67815c59a4d896c6fe
+ sha1sums = fd9b79fc4b81703549b266afe55b6b1598722d1b
pkgname = mozc-ut
pkgdesc = Mozc the Japanese Input Method with Mozc UT Dictionary
diff --git a/PKGBUILD b/PKGBUILD
index 94808a41e633..672c80f0cf67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -72,15 +72,15 @@ _bldtype=Release
#_bldtype=Debug
_mozcrev=2628af6995dbbbb9ccdb52d1160db1dbd5ed3bae
-_utdicver=20160125
+_utdicver=20160303
_zipcoderel=201602
_uimmozcrev=321.3ea28b1
pkgbase=mozc-ut
pkgname=mozc-ut
true && pkgname=('mozc-ut')
-pkgver=2.17.2313.102.20160125
-pkgrel=2
+pkgver=2.17.2313.102.20160303
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.geocities.jp/ep3797/mozc_01.html"
license=('BSD' 'GPL' 'CC-BY-SA' 'custom')
@@ -95,12 +95,12 @@ source=(
mod-generate-mozc-ut.sh
)
sha1sums=('SKIP'
- 'c0e7d8e9d2a3dcc41effda4901f5142820565bf5'
- '701737f457cd0a1832ff5e6ed961cf1d6317d5b7'
+ '4db23b05c9a7d6a6fbc57f5714f2ce58b12d582f'
+ 'a56267cdf87b5ea48c378107da180f45b7beb46a'
'e0ba18e67c1be8e3cfb8ecb30760597b215da255'
'5cc2c2811e2a57ebaf671d09d727a86009f7f846'
'4ba7faa2ebecb4ad52e05d92d7d18abae327a4fc'
- '3b525b6802251c07d8cb3f67815c59a4d896c6fe')
+ 'fd9b79fc4b81703549b266afe55b6b1598722d1b')
if [[ "$_ibus_mozc" == "yes" ]]; then
@@ -140,6 +140,13 @@ prepare() {
git submodule update --init --recursive
+ # Generate zip code seed
+ msg "Generating zip code seed..."
+ python2 src/dictionary/gen_zip_code_seed.py \
+ --zip_code="${srcdir}/x-ken-all.csv" --jigyosyo="${srcdir}/JIGYOSYO.CSV" \
+ >> src/data/dictionary_oss/dictionary09.txt
+ msg "Done."
+
cd "${srcdir}/mozcdic-ut-${_utdicver}"
_mozcver=`mozcver`
@@ -163,13 +170,6 @@ prepare() {
fi
- # Generate zip code seed
- msg "Generating zip code seed..."
- python2 dictionary/gen_zip_code_seed.py \
- --zip_code="${srcdir}/x-ken-all.csv" --jigyosyo="${srcdir}/JIGYOSYO.CSV" \
- >> data/dictionary_oss/dictionary09.txt
- msg "Done."
-
# Extract liccense part of mozc
head -n 29 server/mozc_server.cc > LICENSE
}
diff --git a/mod-generate-mozc-ut.sh b/mod-generate-mozc-ut.sh
index 983b85345dea..95a2da2b31fc 100755
--- a/mod-generate-mozc-ut.sh
+++ b/mod-generate-mozc-ut.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/bash
+#!/usr/bin/bash -e
[[ ! -f generate-mozc-ut.sh ]] && { echo "generate-mozc-ut.sh not found."; exit 1; }
@@ -6,7 +6,7 @@ sed -i \
-e '1s/bash/bash -e/' \
-e 's/ruby \(.*\)/ruby -EUTF-8 \1/g' \
generate-mozc-ut.sh \
- edict-katakanago/generate-katakanago.sh
+ edict-katakana-english/generate-katakanago.sh
sed -i \
-e 's/^\(MOZCVER=.*\|DICVER=.*\|NICODIC=.*\)/#&/' \
@@ -17,8 +17,8 @@ sed -i \
-e '/rm -rf ..\/mozc-$MOZCVER\//d' \
-e 's|mozc-\$MOZCVER|mozc/src|g' \
-e '/# unpack official mozc/,+6d' \
- -e '/# generate zip code dic/,+11d' \
- -e '/# debian\/rules/,+2d' \
+ -e '/wget http:\/\/www.post.japanpost.jp\/zipcode\/dl\/kogaki\/zip\/ken_all.zip/,+13d' \
+ -e '/# modify zip code data/,+3d' \
-e '/# PKGBUILD/,+2d' \
-e '/# compress mozc-ut/,+4d' \
generate-mozc-ut.sh
@@ -26,6 +26,6 @@ sed -i \
sed -i \
-e '/# get edict/,+1d' \
-e 's|gzip -d edict.gz|ln -sf \.\./\.\./edict-${DICVER} edict|' \
- edict-katakanago/generate-katakanago.sh
+ edict-katakana-english/generate-katakanago.sh
-sed -i '71s/s\[5\]/& != "" and &/' chimei/get-entries.rb
+#sed -i '71s/s\[5\]/& != "" and &/' chimei/get-entries.rb