summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato HASHIMOTO2016-03-03 21:52:46 +0900
committerMasato HASHIMOTO2016-03-03 21:52:46 +0900
commit3e5e00e7830c2b829a5e10ed1ab5c6831a265da1 (patch)
tree3cd41004b89125de193d8cd67508c3031056cc4d
parente2dfd41da564914b2ffad90de9981bd2264fd6a2 (diff)
downloadaur-3e5e00e7830c2b829a5e10ed1ab5c6831a265da1.tar.gz
Fix bug to get pkgver and improve to set kill-line opton
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b879060ccbcd..fdbb10854f6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# 水 1月 27 12:46:17 UTC 2016
+# 木 3月 3 12:52:45 UTC 2016
pkgbase = mozc-ut
pkgdesc = Mozc the Japanese Input Method with Mozc UT Dictionary (additional dictionary) and uim-mozc (optional)
pkgver = 2.17.2313.102.20160125
@@ -23,15 +23,15 @@ pkgbase = mozc-ut
source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/mozcdic-ut-20160125.tar.bz2
source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/edict-20160125.gz
source = EDICT_license.html
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201512.zip
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201512.zip
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201602.zip
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201602.zip
source = mod-generate-mozc-ut.sh
sha1sums = SKIP
sha1sums = c0e7d8e9d2a3dcc41effda4901f5142820565bf5
sha1sums = 701737f457cd0a1832ff5e6ed961cf1d6317d5b7
sha1sums = e0ba18e67c1be8e3cfb8ecb30760597b215da255
- sha1sums = b07c667a82fd31c752a973c8bee06dab8178c3f0
- sha1sums = 11636b6256f3382d11ac4df41db243acd33a44b3
+ sha1sums = 5cc2c2811e2a57ebaf671d09d727a86009f7f846
+ sha1sums = 4ba7faa2ebecb4ad52e05d92d7d18abae327a4fc
sha1sums = 3b525b6802251c07d8cb3f67815c59a4d896c6fe
pkgname = mozc-ut
diff --git a/PKGBUILD b/PKGBUILD
index b2cf9dbe1bae..d246e72fcd30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,19 @@
_ibus_mozc="yes"
## If you will be using uim, uncomment below.
#_uim_mozc="yes"
-## If applying patch for uim-mozc fails, try to uncomment below.
-_kill_kill_line="yes"
-## This will disable the 'kill-line' feature of uim-mozc.
## If you will be using mozc.el on Emacs, uncomment below.
#_emacs_mozc="yes"
+## If you want to use 'kill-line' feature of uim, uncomment below.
+#_kill_line="yes"
+## NOTE: This option affects only for uim users.
+## Bcause this applies a patch to original mozc source,
+## there is a possibility to fail depends on the mozc version.
+
## ニコニコ大百科IME辞書 (NICONICOPEDIA IME dictionary, see below)
#_NICODIC="true"
-
#***********************************************************************
# License information:
#
@@ -125,7 +127,7 @@ mozcver() {
pkgver() {
- printf "%s.%s" `mozcver` "${_utdicver}"
+ printf "%s.%s" $_mozcver "${_utdicver}"
}
@@ -147,13 +149,13 @@ prepare() {
./generate-mozc-ut.sh
msg "Done."
- cd "${srcdir}/${pkgbase}-${pkgver}"
+ cd "${srcdir}/${pkgbase}-`pkgver`"
# uim-mozc
if [[ "$_uim_mozc" == "yes" ]]; then
cp -rf "${srcdir}/uim-mozc-${_uimmozcrev}/uim" unix/
# kill-line patch
- if [[ "$_kill_kill_line" != "yes" ]]; then
+ if [[ "$_kill_line" == "yes" ]]; then
patch -p0 -i "${srcdir}/uim-mozc-${_uimmozcrev}/mozc-kill-line.diff"
fi
# Extract license part of uim-mozc