summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2022-07-26 10:35:59 +0800
committerBrLi2022-07-26 10:35:59 +0800
commit77bdde9023b2235d84134a076d985ef2fbf379c7 (patch)
tree4c8a22ae6a89e97ca38dbed058a5b9b810ef375e
parent8f41ffc2029996d1c0c7a32837e1f9970fcf0421 (diff)
downloadaur-77bdde9023b2235d84134a076d985ef2fbf379c7.tar.gz
updpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5829d683ff2..4f74143cb7af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = mozc-ut-full
- pkgver = 2.28.4770.102.20220623
+ pkgver = 2.28.4800.102.20220723
pkgrel = 1
url = https://github.com/fcitx/mozc
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = mozc-ut-full
makedepends = qt5-base
makedepends = ibus
makedepends = gyp
- source = git+https://github.com/fcitx/mozc.git#commit=62028fb
+ source = git+https://github.com/fcitx/mozc.git#commit=0ee47ed
source = https://osdn.net/projects/ponsfoot-aur/storage/mozc/x-ken-all-202110.zip
source = https://osdn.net/projects/ponsfoot-aur/storage/mozc/jigyosyo-202110.zip
source = git+https://github.com/abseil/abseil-cpp.git#commit=2151058
@@ -28,7 +28,7 @@ pkgbase = mozc-ut-full
source = git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git#commit=e5b3425
source = git+https://github.com/open-source-parsers/jsoncpp.git#commit=11086dd
source = git+https://github.com/google/protobuf.git#commit=cc7b1b5
- source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-20220623.tar.bz2
+ source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-20220723.tar.bz2
validpgpkeys = 2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9
sha512sums = SKIP
sha512sums = dec6479b42ddc1355cd882d17824cd874d8f103ad7767bac3f490f04551059d65b2806fa9e3f39a50ced2ecfdd37b75c9ed4536d9ad3bcef9e8c5ae1ec10e302
@@ -40,7 +40,7 @@ pkgbase = mozc-ut-full
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = d8a83ec55d993885333d31e4e2b31f240463766ed3f5b4e8de0887fc7f3e79096c872365029de8ee5234dcd514e7f734b608af1a3a1568f308c8ac6fa7a0865c
+ sha512sums = 6fa5a6c9f97d97216d7fb4711299d3322667252a2dd74db08257edafaa3affc6db837cd9daa2c81cd4235d1c8418a10c10b22a3a6ef32aff33e69d7ec21daa5e
pkgname = mozc-ut-full-common
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
diff --git a/PKGBUILD b/PKGBUILD
index 0b3204303183..cb69faccaecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
## Mozc compile option
_bldtype='Release'
-_mozc_commit=62028fb
+_mozc_commit=0ee47ed
_abseil_cpp_commit=2151058
_breakpad_commit=216cea7
_gtest_commit=703bd9c
@@ -17,12 +17,12 @@ _protobuf_commit=cc7b1b5
_zipcode_rel=202110
# Ut Dictionary
-_utdicdate=20220623
+_utdicdate=20220723
_pkgbase=mozc-ut
pkgbase=$_pkgbase-full
pkgname=(${pkgbase}-common ibus-${pkgbase} fcitx5-${pkgbase} emacs-${pkgbase})
-pkgver=2.28.4770.102.20220623
+pkgver=2.28.4800.102.20220723
pkgrel=1
arch=('x86_64')
url="https://github.com/fcitx/mozc"
@@ -49,7 +49,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'd8a83ec55d993885333d31e4e2b31f240463766ed3f5b4e8de0887fc7f3e79096c872365029de8ee5234dcd514e7f734b608af1a3a1568f308c8ac6fa7a0865c')
+ '6fa5a6c9f97d97216d7fb4711299d3322667252a2dd74db08257edafaa3affc6db837cd9daa2c81cd4235d1c8418a10c10b22a3a6ef32aff33e69d7ec21daa5e')
validpgpkeys=('2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9') # Weng Xuetian
pkgver() {
@@ -107,7 +107,7 @@ build() {
python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
python build_mozc.py build -c $_bldtype $_targets --use_gyp_for_ibus_build
- sed -i 's|/usr/libexec/|/usr/lib/ibus-mozc/|g' out_linux/${_bldtype}/gen/unix/ibus/mozc.xml
+ sed 's|/usr/libexec/|/usr/lib/ibus-mozc/|g' -i "out_linux/${_bldtype}/gen/unix/ibus/mozc.xml"
# Extract license part of mozc
head -n 29 server/mozc_server.cc > LICENSE
@@ -120,7 +120,7 @@ package_mozc-ut-full-common() {
export _bldtype
cd mozc/src
- install -d "${pkgdir}/usr/share/licenses/$pkgname/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
install -m 644 LICENSE data/installer/*.html "${pkgdir}/usr/share/licenses/${pkgname}/"
../scripts/install_server