summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMASAKI Haruka2020-06-11 23:18:11 +0900
committerMASAKI Haruka2020-06-11 23:18:11 +0900
commit4099370780f94c01ad06fcebfaaf0cda0490e393 (patch)
tree0e2431a46d28abf23dc2f2e1d005bbb12754aa5c
downloadaur-4099370780f94c01ad06fcebfaaf0cda0490e393.tar.gz
Initial import
-rw-r--r--.SRCINFO72
-rw-r--r--PKGBUILD105
2 files changed, 177 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eee4cadab45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,72 @@
+pkgbase = mozc-ut-unified
+ pkgver = 2.23.2815.102.20200611
+ pkgrel = 1
+ url = https://osdn.net/users/utuhiro/pf/utuhiro/files/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = clang
+ makedepends = gyp
+ makedepends = ninja
+ makedepends = pkg-config
+ makedepends = python
+ makedepends = curl
+ makedepends = gtk2
+ makedepends = qt5-base
+ makedepends = zinnia
+ makedepends = fcitx
+ makedepends = libxcb
+ makedepends = glib2
+ makedepends = bzip2
+ makedepends = unzip
+ source = http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_2.23.2815.102+dfsg.orig.tar.xz
+ source = protobuf-3.5.2.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.5.2.tar.gz
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/usage_dict.txt.patch
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Fix-build-with-gcc8.patch
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Change-from-python2-code-to-python3.patch
+ source = https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/add_support_new_japanese_era.patch
+ source = https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-2.23.2815.102.1.patch
+ source = https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
+ source = https://osdn.net/downloads/users/26/26429/mozcdic-ut-20200611.1.tar.bz2
+ sha1sums = 7e0a39ffd5ea68ecadb792fc521c16b5be1f25cb
+ sha1sums = d0c551031828ed9c07cc683762353a67b1a17627
+ sha1sums = c6f5aac79c7e98fbda96de251d8f0d0787344ca9
+ sha1sums = 4fe935b5c2d316119cf8957b6518b3b5e7bf6ecf
+ sha1sums = SKIP
+ sha1sums = 13f8fbbc768d5042fb55d877acf2a73fc8b5e3f0
+ sha1sums = 63a2b10e7d209c6216e2d912b2629efc44c637ea
+ sha1sums = 883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d
+ sha1sums = c61180076bbf61b4fab53c4bbc4ecf6f7cf23724
+
+pkgname = mozc-ut-unified
+ pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary.
+ arch = i686
+ arch = x86_64
+ depends = qt5-base
+ depends = zinnia
+ conflicts = fcitx-mozc
+ conflicts = mozc
+ conflicts = fcitx-mozc-ut2
+ conflicts = mozc-ut2
+ conflicts = fcitx-mozc-ut
+ conflicts = mozc-ut
+ conflicts = fcitx-mozc-neologd-ut
+ conflicts = mozc-neologd-ut
+ conflicts = fcitx-mozc-neologd-ut+ut2
+
+pkgname = fcitx-mozc-ut-unified
+ pkgdesc = Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary.
+ arch = i686
+ arch = x86_64
+ depends = mozc-ut-unified=2.23.2815.102.20200611
+ depends = fcitx
+ conflicts = fcitx-mozc
+ conflicts = mozc
+ conflicts = fcitx-mozc-ut2
+ conflicts = mozc-ut2
+ conflicts = fcitx-mozc-ut
+ conflicts = mozc-ut
+ conflicts = fcitx-mozc-neologd-ut
+ conflicts = mozc-neologd-ut
+ conflicts = fcitx-mozc-neologd-ut+ut2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab1910e81e66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,105 @@
+# Maintainer: Masaki Haruka <yek at reasonset dot net>
+# Contributor: UTUMI Hirosi <utuhiro78 at yahoo dot co dot jp>
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+## Mozc compile option
+_bldtype=Release
+
+_mozcver=2.23.2815.102
+_fcitxver=2.23.2815.102.1
+_utdicdate=20200611
+pkgver=${_mozcver}.${_utdicdate}
+pkgrel=1
+
+pkgname=mozc-ut-unified
+true && pkgname=('mozc-ut-unified' 'fcitx-mozc-ut-unified')
+arch=('i686' 'x86_64')
+url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
+license=('custom')
+makedepends=('clang' 'gyp' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'zinnia' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
+
+source=(
+ http://ftp.jp.debian.org/debian/pool/main/m/mozc/mozc_${_mozcver}+dfsg.orig.tar.xz
+ protobuf-3.5.2.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.5.2.tar.gz
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/usage_dict.txt.patch
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Fix-build-with-gcc8.patch
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/Change-from-python2-code-to-python3.patch
+ https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/add_support_new_japanese_era.patch
+ https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-${_fcitxver}.patch
+ https://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz
+ https://osdn.net/downloads/users/26/26429/mozcdic-ut-${_utdicdate}.${pkgrel}.tar.bz2
+)
+
+sha1sums=(
+ '7e0a39ffd5ea68ecadb792fc521c16b5be1f25cb'
+ 'd0c551031828ed9c07cc683762353a67b1a17627'
+ 'c6f5aac79c7e98fbda96de251d8f0d0787344ca9'
+ '4fe935b5c2d316119cf8957b6518b3b5e7bf6ecf'
+ 'SKIP'
+ '13f8fbbc768d5042fb55d877acf2a73fc8b5e3f0'
+ '63a2b10e7d209c6216e2d912b2629efc44c637ea'
+ '883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d'
+ 'c61180076bbf61b4fab53c4bbc4ecf6f7cf23724'
+)
+
+prepare() {
+ cd mozc-${_mozcver}+dfsg
+ mkdir -p src/third_party
+ mv ${srcdir}/protobuf-3.5.2 src/third_party/protobuf
+ patch -Np1 -i ${srcdir}/usage_dict.txt.patch
+ patch -Np1 -i ${srcdir}/Fix-build-with-gcc8.patch
+ patch -Np1 -i ${srcdir}/Change-from-python2-code-to-python3.patch
+ patch -Np1 -i ${srcdir}/add_support_new_japanese_era.patch
+ patch -Np1 -i ${srcdir}/fcitx-mozc-${_fcitxver}.patch
+
+ # Avoid fcitx5 build errors
+ rm -rf src/unix/fcitx5/
+
+ # Add UT dictionary
+ cat ${srcdir}/mozcdic-ut-${_utdicdate}.${pkgrel}/mozcdic*-ut-*.txt >> src/data/dictionary_oss/dictionary00.txt
+}
+
+build() {
+ cd mozc-${_mozcver}+dfsg/src
+
+ _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool renderer/renderer.gyp:mozc_renderer unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n"
+
+ GYP_DEFINES="use_libzinnia=1 document_dir=/usr/share/licenses/mozc" python build_mozc.py gyp --gypdir=/usr/bin --target_platform=Linux
+ python build_mozc.py build -c $_bldtype $_targets
+}
+
+package_mozc-ut-unified() {
+ pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with NEologd UT dictionary and UT2 dictionary."
+ arch=('i686' 'x86_64')
+ depends=('qt5-base' 'zinnia')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2')
+ cd mozc-${_mozcver}+dfsg/src
+ install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
+ install -m 755 out_linux/${_bldtype}/mozc_tool "${pkgdir}/usr/lib/mozc/mozc_tool"
+
+ install -d "${pkgdir}/usr/share/licenses/$pkgname/"
+ install -m 644 ../LICENSE data/installer/*.html "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+package_fcitx-mozc-ut-unified() {
+ pkgdesc="Fcitx engine module for Mozc with NEologd UT dictionary and UT2 dictionary."
+ arch=('i686' 'x86_64')
+ depends=("mozc-ut-unified=${pkgver}" 'fcitx')
+ conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut' 'fcitx-mozc-neologd-ut' 'mozc-neologd-ut' 'fcitx-mozc-neologd-ut+ut2')
+
+ cd mozc-${_mozcver}+dfsg/src
+ for mofile in out_linux/${_bldtype}/gen/unix/fcitx/po/*.mo
+ do
+ filename=`basename $mofile`
+ lang=${filename/.mo/}
+ install -D -m 644 "$mofile" "${pkgdir}/usr/share/locale/$lang/LC_MESSAGES/fcitx-mozc.mo"
+ done
+
+ install -D -m 755 out_linux/${_bldtype}/fcitx-mozc.so "${pkgdir}/usr/lib/fcitx/fcitx-mozc.so"
+ install -D -m 644 unix/fcitx/fcitx-mozc.conf "${pkgdir}/usr/share/fcitx/addon/fcitx-mozc.conf"
+ install -D -m 644 unix/fcitx/mozc.conf "${pkgdir}/usr/share/fcitx/inputmethod/mozc.conf"
+
+ install -d ${pkgdir}/usr/share/fcitx/mozc/icon
+ install -m 644 ${srcdir}/fcitx-mozc-icons/*.png ${pkgdir}/usr/share/fcitx/mozc/icon/
+}