summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-05-12 01:40:38 +0200
committerXZS2016-05-12 02:02:33 +0200
commit6f6b00f2ed505cc64d29850d3128dc3141e8b235 (patch)
tree945363d1f86596ca871c649bc3f77cc03d5bdf9d
parentdeb71c207054cb42158abb80694ba8093e8b309d (diff)
downloadaur-6f6b00f2ed505cc64d29850d3128dc3141e8b235.tar.gz
provide stable variant
Mozilla plans to disallow the installation of unsigned extensions without override from coming version 47 on. [1] Signed variants can usually only be retrieved from addons.mozilla.org. So the new package ensures that users of unmodified Firefox can continue to use the respective Add-Ons in the future. [1]: https://wiki.mozilla.org/Add-ons/Extension_Signing
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD42
2 files changed, 36 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b42b7c3f401..f9143f129824 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,30 @@
-pkgbase = mozilla-extension-gnome-keyring-git
+pkgbase = mozilla-extension-gnome-keyring
pkgdesc = Mozilla extension to store passwords and form logins in gnome-keyring.
pkgver = 0.11
- pkgrel = 4
- url = https://github.com/swick/mozilla-gnome-keyring
+ pkgrel = 1
+ url = https://addons.mozilla.org/mozilla/addon/mozilla-gnome-keyring/
arch = any
license = GPLv3
- makedepends = git
+ makedepends = unzip
makedepends = rasqal
depends = libgnome-keyring
- provides = mozilla-extension-gnome-keyring=0.11
- conflicts = mozilla-extension-gnome-keyring
- source = mozilla-extension-gnome-keyring::git+https://github.com/swick/mozilla-gnome-keyring
+ noextract = mozilla-extension-gnome-keyring.zip
+ source = mozilla-extension-gnome-keyring.zip::https://addons.mozilla.org/firefox/downloads/latest/mozilla-gnome-keyring/platform:2/
+ source = .version::https://services.addons.mozilla.org/firefox/api/1.5/addon/mozilla-gnome-keyring
+ md5sums = 01360c61d9587f233552155f4cb9db41
md5sums = SKIP
-pkgname = mozilla-extension-gnome-keyring-git
+pkgname = mozilla-extension-gnome-keyring
-pkgname = firefox-extension-gnome-keyring-git
- depends = mozilla-extension-gnome-keyring-git=0.11
+pkgname = firefox-extension-gnome-keyring
+ depends = mozilla-extension-gnome-keyring=0.11
depends = firefox
- provides = firefox-extension-gnome-keyring
- conflicts = firefox-extension-gnome-keyring
+ provides =
+ conflicts =
-pkgname = thunderbird-extension-gnome-keyring-git
- depends = mozilla-extension-gnome-keyring-git=0.11
+pkgname = thunderbird-extension-gnome-keyring
+ depends = mozilla-extension-gnome-keyring=0.11
depends = thunderbird
- provides = thunderbird-extension-gnome-keyring
- conflicts = thunderbird-extension-gnome-keyring
+ provides =
+ conflicts =
diff --git a/PKGBUILD b/PKGBUILD
index 049e3a5d3220..4503e2ab41ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
# Maintainer: XZS <d dot f dot fischer at web dot de>
-# Contributor: hashstat <hashstat .AT. yahoo .DOT. com>
-# Contributor: Anshuman Bhaduri <anshuman dot bhaduri0 at gmail dot com>
-# Contributor: bzt <unmacaque@gmail.com>
# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/mozilla-extensions>.
# You may find it convenient to file issues and pull requests there.
-pkgname=mozilla-extension-gnome-keyring-git
+pkgname=mozilla-extension-gnome-keyring
pkgver=0.11
-pkgrel=4
+pkgrel=1
pkgdesc="Mozilla extension to store passwords and form logins in gnome-keyring."
arch=(any)
-url='https://github.com/swick/mozilla-gnome-keyring'
+_extname=mozilla-gnome-keyring
license=(GPLv3)
depends=(libgnome-keyring)
optdepends=(firefox thunderbird)
+md5sums=('01360c61d9587f233552155f4cb9db41')
-makedepends+=('git')
-source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
+[ "$arch" ] || arch=('any')
+
+source+=(
+ "${pkgname}.zip::https://addons.mozilla.org/firefox/downloads/latest/${_extname=${pkgname#*-*-}}/platform:2/"
+ ".version::https://services.addons.mozilla.org/firefox/api/1.5/addon/$_extname"
+)
+[ ${url++} ] || url="https://addons.mozilla.org/${pkgname%%-*}/addon/$_extname/"
md5sums+=('SKIP')
-provides+=("$_gitname=$pkgver")
-conflicts+=("$_gitname")
+noextract+=("${pkgname}.zip")
+makedepends+=(unzip)
-# Move down repository content for easier access by following functions.
prepare() {
- cp -rfT --reflink=auto "$_gitname" .
- rm -rf "$_gitname"
+ unzip "${pkgname}.zip"
+ rm ${pkgname}.zip
}
makedepends+=(rasqal)
@@ -34,21 +36,15 @@ sparql() {
-D "${2:-install.rdf}" -r csv 2>/dev/null | tr -d '\r' | tail -n 1 | head -c -1
}
-# Retrieve current compatibility information from install.rdf.
-query-version() {
- sparql "[] em:id '$2' ; em:${1}Version ?x" install.rdf
-}
-
pkgver() {
sparql '<urn:mozilla:install-manifest> em:version ?x' | tr - .
- echo -n .
-printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- rm LICENSE Makefile
+# Retrieve current compatibility information from addons.mozilla.org API.
+query-version() {
+ xmllint .version --xpath \
+ "//application[appID='$2']/$1_version/text()"
}
-
eval "package_$pkgname()" '{
prepare_target
cp --no-preserve=ownership,mode -r . "$destdir/$id"