summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:29:44 +0100
committerXZS2016-10-31 18:29:44 +0100
commitf1f5f41fdae1ce162606885329a4857ee0cadbf0 (patch)
tree3dfff48aba6c105a206d7e5a393faaefb3e93370
parentcd66e06dd976a46ba99aa3870a2fdbeed1bda530 (diff)
downloadaur-f1f5f41fdae1ce162606885329a4857ee0cadbf0.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e9769b968dc..8d3d3c3cad73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozilla-extension-gnome-keyring
pkgdesc = Mozilla extension to store passwords and form logins in gnome-keyring.
pkgver = 0.12
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/mozilla/addon/mozilla-gnome-keyring/
arch = any
license = GPLv3
diff --git a/PKGBUILD b/PKGBUILD
index bae41d197d3a..d99c6adc441d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mozilla-extension-gnome-keyring
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="Mozilla extension to store passwords and form logins in gnome-keyring."
arch=(any)
_extname=mozilla-gnome-keyring
@@ -64,9 +64,18 @@ for target in "${optdepends[@]}"; do
done
optdepends=()
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {