summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:30:47 +0100
committerXZS2016-10-31 18:30:47 +0100
commit720d1d1e49c9ff4b5120a6cf254193d167c71923 (patch)
tree630f510e554630fcafc8c6f01c503e4b651a8e2d
parente193429651e6aaabe66191299a13649e5ef0b367 (diff)
downloadaur-720d1d1e49c9ff4b5120a6cf254193d167c71923.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f63a0bfa010..1a689989dc67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozilla-extension-gnome-keyring-git
pkgdesc = Mozilla extension to store passwords and form logins in gnome-keyring.
pkgver = 0.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/swick/mozilla-gnome-keyring
arch = any
license = GPLv3
diff --git a/PKGBUILD b/PKGBUILD
index 4501f940b888..bf2657628d70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mozilla-extension-gnome-keyring-git
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="Mozilla extension to store passwords and form logins in gnome-keyring."
arch=(any)
url='https://github.com/swick/mozilla-gnome-keyring'
@@ -72,9 +72,18 @@ for target in "${optdepends[@]}"; do
done
optdepends=()
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {