summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-15 18:43:59 +0200
committerXZS2016-04-15 18:43:59 +0200
commit4d74d46edd22b2ec94c0d7d3b25fd9f6f1bcb3cb (patch)
tree72a9eef5c23bf2f1f037688c052afbee7d889f9b
parent54db05713bca3a8ee54744c0e7a3a4449ad5a71e (diff)
downloadaur-4d74d46edd22b2ec94c0d7d3b25fd9f6f1bcb3cb.tar.gz
generate bootstrap.js
Without this file, the extension only works partially, for example lacking user settings. Unfortunately, the tool generating it pulls in a whole lot of nodejs dependencies and cannot do so without packing all the files as an xpi, which has to be extracted again for installation.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf93e86d902f..b23e9553cbc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = mozilla-extension-gnotifier-git
pkgdesc = Add-on for Firefox and Thunderbird to enable integration with GNOME native notification system.
pkgver = 1.9.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mkiol/GNotifier
arch = any
license = GPL3
+ makedepends = nodejs-jpm
+ makedepends = unzip
makedepends = git
makedepends = rasqal
depends = libnotify
diff --git a/PKGBUILD b/PKGBUILD
index b493a5ba00cf..c740a884d048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@
pkgname=mozilla-extension-gnotifier-git
pkgver=1.9.5
-pkgrel=1
+pkgrel=2
pkgdesc='Add-on for Firefox and Thunderbird to enable integration with GNOME native notification system.'
url='https://github.com/mkiol/GNotifier'
arch=('any')
license=('GPL3')
depends=('libnotify')
+makedepends=('nodejs-jpm' 'unzip')
optdepends=(firefox thunderbird)
makedepends+=('git')
@@ -47,6 +48,9 @@ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
build() {
cp -r --reflink=auto source/* .
rm -r xpi misc *.md win8* source
+ jpm xpi
+ unzip -o *.xpi
+ rm *.xpi
}
eval "package_$pkgname()" '{