summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2017-03-11 14:06:59 +0100
committerXZS2017-03-11 14:06:59 +0100
commit6402d683f61c027539b19277bd78506ad6c12c72 (patch)
treedffb75ce51a329a18810dda09eaf8d88459373e2
parent5f67e4fb583dd46d156277ef749f8d653ea8a1cf (diff)
downloadaur-6402d683f61c027539b19277bd78506ad6c12c72.tar.gz
expand release file syntax
Files appeared that use an underscore instead of a hyphen, so the patterns have to adapt to find the correct version number again. As the still noted version 1.9.8 can be parsed using the old pattern, this does not trigger a pkgrel change. But it enables the next pkgver update to begin with.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8a465c9b8d0..839ba0fe4c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,11 +42,11 @@ query-version() {
}
pkgver() {
- find xpi -name "gnotifier-$(
+ find xpi -regextype egrep -name "gnotifier[_-]$(
find -iname '*.json' -exec sed -n \
's/.*"version"\s*:\s*"\([[:digit:].]*\)"\s*,.*/\1/p' \
'{}' \; -quit 2>/dev/null
- )*" -printf '%f\n' | sed 's/^gnotifier-\(.*\).xpi$/\1/;
+ )*" -printf '%f\n' | sed 's/^gnotifier[-_]\(.*\).xpi$/\1/;
s/-final$//;s/-//' | sort -n | head -n1 | tr '\n' '.'
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}