summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2021-06-18 12:58:38 -0700
committerXavierCLL2021-06-18 12:58:38 -0700
commit539fe105b63526bdaf5b0eb306f77e36910a40cb (patch)
treec1ba3c2e4f4130b3cc0dc911b695a47655c92280
parentb676bc96babb03ce53cc3d60e59455f9fb99d92f (diff)
downloadaur-539fe105b63526bdaf5b0eb306f77e36910a40cb.tar.gz
Rollback to 2.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
-rw-r--r--mozillavpn.service7
3 files changed, 27 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ce218099d11..c9d54db310d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozillavpn
pkgdesc = A fast, secure and easy to use VPN. Built by the makers of Firefox.
- pkgver = 2.3.1
- pkgrel = 3
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://vpn.mozilla.org/
arch = i686
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = mozillavpn
depends = hicolor-icon-theme
depends = wireguard-tools
depends = WIREGUARD-MODULE
- source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.3.1-hirsute1/mozillavpn_2.3.1.orig.tar.gz
- source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.3.1-hirsute1/mozillavpn_2.3.1-hirsute1.debian.tar.xz
- sha256sums = 4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f
- sha256sums = af3ff4ea259e8d23c040671345c323b77e352d7c3c65c4b6384ca21efae73960
+ conflicts = mozilla-vpn-client
+ replaces = mozilla-vpn-client
+ source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.2.0-focal1/mozillavpn_2.2.0.orig.tar.gz
+ sha256sums = 025e56d23bccc141ef2cfe356f403a1946b0a676f2d298649b921ad387e8d640
pkgname = mozillavpn
diff --git a/PKGBUILD b/PKGBUILD
index b1076865be9a..2c2ef059891d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: Tavian Barnes <tavianator@tavianator.com>
pkgname=mozillavpn
-pkgver=2.3.1
-pkgrel=3
+pkgver=2.2.0
+pkgrel=1
+epoch=
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
license=('GPL')
+groups=()
depends=('polkit'
'qt5-charts'
'qt5-declarative'
@@ -19,20 +20,25 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE')
makedepends=('qt5-tools')
-# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=(
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}.orig.tar.gz"
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}-hirsute1.debian.tar.xz")
-sha256sums=('4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f'
- 'af3ff4ea259e8d23c040671345c323b77e352d7c3c65c4b6384ca21efae73960')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=('mozilla-vpn-client')
+replaces=('mozilla-vpn-client')
+backup=()
+options=()
+install=
+changelog=
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-focal1/${pkgname}_${pkgver}.orig.tar.gz")
+noextract=()
+sha256sums=('025e56d23bccc141ef2cfe356f403a1946b0a676f2d298649b921ad387e8d640')
+validpgpkeys=()
build() {
- qmake PREFIX=/usr CONFIG+=production
- make
+ qmake PREFIX=/usr CONFIG+=production CONFIG-=debug CONFIG+=release CONFIG-=debug_and_release
+ make
}
package() {
- make INSTALL_ROOT="$pkgdir" install
- install -dm 755 "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "debian/mozillavpn.service" "$pkgdir/usr/lib/systemd/system"
+ make INSTALL_ROOT="$pkgdir" install
}
diff --git a/mozillavpn.service b/mozillavpn.service
deleted file mode 100644
index 624bfc0a5fd0..000000000000
--- a/mozillavpn.service
+++ /dev/null
@@ -1,7 +0,0 @@
-[Unit]
-Description=MozillaVPN D-Bus service
-
-[Service]
-Type=dbus
-BusName=org.mozilla.vpn.dbus
-ExecStart=/usr/bin/mozillavpn linuxdaemon