summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier C. Llano2023-12-07 22:19:08 -0500
committerXavier C. Llano2023-12-07 22:19:08 -0500
commit7e097f9c114d264515bad9f5ddee76538e0abdd3 (patch)
tree32d81ca08f52a2376b461621c9a65ad8d8fda91b
parent01c82185de0fe747d9a0baea25e0a4ce68281af7 (diff)
downloadaur-7e097f9c114d264515bad9f5ddee76538e0abdd3.tar.gz
v2.19.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD102
-rw-r--r--mozillavpn.install10
4 files changed, 67 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1cc1d78627b..94de57846162 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = mozillavpn
pkgdesc = A fast, secure and easy to use VPN. Built by the makers of Firefox.
- pkgver = 2.16.1
+ pkgver = 2.19.0
pkgrel = 1
url = https://mozilla.org/products/vpn
+ install = mozillavpn.install
arch = x86_64
license = MPL2
- makedepends = git
makedepends = cmake
makedepends = qt6-tools
makedepends = go
- makedepends = clang
- makedepends = cargo
+ makedepends = flex
makedepends = python-yaml
makedepends = python-lxml
- makedepends = python-glean-parser
- makedepends = yamllint
+ makedepends = clang
+ makedepends = cargo
depends = polkit
depends = libxcb
depends = libxmu
@@ -33,10 +32,10 @@ pkgbase = mozillavpn
depends = qt6-shadertools
depends = hicolor-icon-theme
depends = wireguard-tools
+ optdepends = resolvconf: for resolv.conf management
optdepends = qt6-wayland: for Wayland support
- optdepends = openresolv: for resolv.conf management
options = !lto
- source = mozillavpn-v2.16.1::git+https://github.com/mozilla-mobile/mozilla-vpn-client.git#tag=v2.16.1
- sha256sums = SKIP
+ source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.19.0-mantic1/mozillavpn_2.19.0.orig.tar.gz
+ sha256sums = 36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03
pkgname = mozillavpn
diff --git a/.gitignore b/.gitignore
index 31d27563afeb..cc67b0b4d0bf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*
!.gitignore
!PKGBUILD
-!.SRCINFO \ No newline at end of file
+!.SRCINFO
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index e955afb4b417..2f9596dfb8fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,61 @@
-# Maintainer: Utsav <aur (a) utsav2 [.] dev>
-# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor: Tavian Barnes <tavianator@tavianator.com>
-# Contributor: jhorcl
-# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
-# Contributor: RafaƂ Wyszomirski <m6vuthzbw at mozmail dot com>
+# XavierCLL <xavier.corredor.llano (a) gmail.com>
pkgname=mozillavpn
-pkgver=2.16.1
+pkgver=2.19.0
+_debian_series=mantic1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('x86_64')
url="https://mozilla.org/products/vpn"
license=('MPL2')
-# See issue: https://github.com/briansmith/ring/issues/1444
options=('!lto')
-depends=('polkit'
- 'libxcb'
- 'libxmu'
- 'libxrender'
- 'libtiff'
- 'libxdmcp'
- 'dbus'
- 'freetype2'
- 'qt6-charts'
- 'qt6-declarative'
- 'qt6-websockets'
- 'qt6-imageformats'
- 'qt6-networkauth'
- 'qt6-svg'
- 'qt6-5compat'
- 'qt6-shadertools'
- 'hicolor-icon-theme'
- 'wireguard-tools')
-makedepends=('git'
- 'cmake'
- 'qt6-tools'
- 'go'
- 'clang'
- 'cargo'
- 'python-yaml'
- 'python-lxml'
- 'python-glean-parser'
- 'yamllint')
-optdepends=('qt6-wayland: for Wayland support'
- 'openresolv: for resolv.conf management')
-# https://github.com/mozilla-mobile/mozilla-vpn-client
-source=(${pkgname}-v${pkgver}::git+https://github.com/mozilla-mobile/mozilla-vpn-client.git#tag=v${pkgver})
-sha256sums=('SKIP')
-
-prepare() {
- cd ${pkgname}-v${pkgver}
- mkdir -p build
-
- git submodule init
- git submodule update
-}
+depends=(
+ 'polkit'
+ 'libxcb'
+ 'libxmu'
+ 'libxrender'
+ 'libtiff'
+ 'libxdmcp'
+ 'dbus'
+ 'freetype2'
+ 'qt6-charts'
+ 'qt6-declarative'
+ 'qt6-websockets'
+ 'qt6-imageformats'
+ 'qt6-networkauth'
+ 'qt6-svg'
+ 'qt6-5compat'
+ 'qt6-shadertools'
+ 'hicolor-icon-theme'
+ 'wireguard-tools'
+)
+optdepends=(
+ 'resolvconf: for resolv.conf management'
+ 'qt6-wayland: for Wayland support'
+)
+makedepends=(
+ 'cmake'
+ 'qt6-tools'
+ 'go'
+ 'flex'
+ 'python-yaml'
+ 'python-lxml'
+ 'clang'
+ 'cargo'
+)
+install=mozillavpn.install
+# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
+sha256sums=('36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03')
build() {
- cd ${pkgname}-v${pkgver}
-
- cmake -S . -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
- cmake --build build -j$(nproc)
+ cd "${pkgname}-${pkgver}"
+ rm -rf build && mkdir build
+ cmake -S . -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ cmake --build build
}
package() {
- cd ${pkgname}-v${pkgver}
- DESTDIR="$pkgdir" cmake --install build
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" cmake --install build
}
diff --git a/mozillavpn.install b/mozillavpn.install
new file mode 100644
index 000000000000..7cda67203e02
--- /dev/null
+++ b/mozillavpn.install
@@ -0,0 +1,10 @@
+post_install() {
+ systemctl daemon-reload
+ systemctl enable mozillavpn.service
+ systemctl start mozillavpn.service
+}
+
+post_upgrade() {
+ systemctl daemon-reload
+ systemctl restart mozillavpn.service
+}