summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2021-06-24 12:37:22 -0700
committerXavierCLL2021-06-24 12:37:22 -0700
commita669e6f294f51a3ccd68754d57839b09fc49faf9 (patch)
tree1b6f0a6c72ad91581046f5a0df5f90eafbf0399f
parent539fe105b63526bdaf5b0eb306f77e36910a40cb (diff)
downloadaur-a669e6f294f51a3ccd68754d57839b09fc49faf9.tar.gz
Return to 2.3.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 21 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9d54db310d1..9ce218099d11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozillavpn
pkgdesc = A fast, secure and easy to use VPN. Built by the makers of Firefox.
- pkgver = 2.2.0
- pkgrel = 1
+ pkgver = 2.3.1
+ pkgrel = 3
url = https://vpn.mozilla.org/
arch = i686
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = mozillavpn
depends = hicolor-icon-theme
depends = wireguard-tools
depends = WIREGUARD-MODULE
- conflicts = mozilla-vpn-client
- replaces = mozilla-vpn-client
- source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.2.0-focal1/mozillavpn_2.2.0.orig.tar.gz
- sha256sums = 025e56d23bccc141ef2cfe356f403a1946b0a676f2d298649b921ad387e8d640
+ source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.3.1-hirsute1/mozillavpn_2.3.1.orig.tar.gz
+ source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.3.1-hirsute1/mozillavpn_2.3.1-hirsute1.debian.tar.xz
+ sha256sums = 4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f
+ sha256sums = af3ff4ea259e8d23c040671345c323b77e352d7c3c65c4b6384ca21efae73960
pkgname = mozillavpn
diff --git a/PKGBUILD b/PKGBUILD
index 2c2ef059891d..b1076865be9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor Tavian Barnes <tavianator@tavianator.com>
pkgname=mozillavpn
-pkgver=2.2.0
-pkgrel=1
-epoch=
+pkgver=2.3.1
+pkgrel=3
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
license=('GPL')
-groups=()
depends=('polkit'
'qt5-charts'
'qt5-declarative'
@@ -20,25 +19,20 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE')
makedepends=('qt5-tools')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=('mozilla-vpn-client')
-replaces=('mozilla-vpn-client')
-backup=()
-options=()
-install=
-changelog=
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-focal1/${pkgname}_${pkgver}.orig.tar.gz")
-noextract=()
-sha256sums=('025e56d23bccc141ef2cfe356f403a1946b0a676f2d298649b921ad387e8d640')
-validpgpkeys=()
+# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
+source=(
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}.orig.tar.gz"
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}-hirsute1.debian.tar.xz")
+sha256sums=('4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f'
+ 'af3ff4ea259e8d23c040671345c323b77e352d7c3c65c4b6384ca21efae73960')
build() {
- qmake PREFIX=/usr CONFIG+=production CONFIG-=debug CONFIG+=release CONFIG-=debug_and_release
- make
+ qmake PREFIX=/usr CONFIG+=production
+ make
}
package() {
- make INSTALL_ROOT="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
+ install -dm 755 "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "debian/mozillavpn.service" "$pkgdir/usr/lib/systemd/system"
}