summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorafontenot2015-08-14 05:31:56 -0700
committerafontenot2015-08-14 05:31:56 -0700
commit22eeba1f7328d8669b98372ae782d375b20472bc (patch)
treefadd18b92bf95785ae2da407c4dea30a31c0c438
downloadaur-22eeba1f7328d8669b98372ae782d375b20472bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7936082ccc1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mozjpeg
+ pkgdesc = JPEG image codec with accelerated baseline decoding and superior encoding
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/mozilla/mozjpeg
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = nasm
+ provides = libjpeg=8.0.2
+ provides = turbojpeg
+ provides = libjpeg-turbo
+ conflicts = libjpeg
+ conflicts = mozjpeg-git
+ conflicts = turbojpeg
+ conflicts = libjpeg-turbo
+ source = https://github.com/mozilla/mozjpeg/archive/v3.1.tar.gz
+ sha1sums = 74b15d4c6e482dd8b238f9344b80b03d2e007641
+
+pkgname = mozjpeg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02878145a94f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: afontenot <adam.m.fontenot@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Simone Sclavi 'Ito' <darkhado@gmail.com>
+# Contributor: N30N <archlinux@alunamation.com>
+
+pkgname="mozjpeg"
+pkgver=3.1
+pkgrel=1
+pkgdesc="JPEG image codec with accelerated baseline decoding and superior encoding"
+url="https://github.com/mozilla/mozjpeg"
+license=("BSD")
+arch=("i686" "x86_64")
+makedepends=("nasm")
+source=("https://github.com/mozilla/${pkgname}/archive/v${pkgver}.tar.gz")
+sha1sums=("74b15d4c6e482dd8b238f9344b80b03d2e007641")
+
+provides=("libjpeg=8.0.2" "turbojpeg" "libjpeg-turbo")
+conflicts=("libjpeg" "mozjpeg-git" "turbojpeg" "libjpeg-turbo")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -fiv
+ ./configure --prefix=/usr --with-jpeg8 --mandir=/usr/share/man
+ make
+}
+
+# much too slow for default, can be enabled if desired
+#check() {
+# cd "${srcdir}/${pkgname}-${pkgver}"
+# make test
+#}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make \
+ DESTDIR="${pkgdir}" \
+ docdir="/usr/share/doc/${pkgname}" \
+ exampledir="/usr/share/doc/${pkgname}" \
+ install
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -t "${pkgdir}/usr/share/licenses/${pkgname}" -s "../../doc/${pkgname}/README"{,-turbo.txt,-mozilla.txt}
+ install -m644 jpegint.h "${pkgdir}/usr/include"
+}