summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorafontenot2022-08-21 11:12:44 -0700
committerafontenot2022-08-21 11:12:44 -0700
commit266abdb6d24db3c689f208b045804e1aa5516155 (patch)
tree80f9bcfb1444903d4c8ef473001501ce6c4a6ed3
parent5bfd77ee7e89c8a093cb12c0e92b6d2b81fab738 (diff)
downloadaur-266abdb6d24db3c689f208b045804e1aa5516155.tar.gz
upstream release v4.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a86da4eb885..998daba43f40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mozjpeg
pkgdesc = JPEG image codec with accelerated baseline decoding and superior encoding
- pkgver = 4.0.3
+ pkgver = 4.1.1
pkgrel = 2
url = https://github.com/mozilla/mozjpeg
arch = i686
@@ -19,7 +19,7 @@ pkgbase = mozjpeg
conflicts = mozjpeg-git
conflicts = turbojpeg
conflicts = libjpeg-turbo
- source = mozjpeg-4.0.3.tar.gz::https://github.com/mozilla/mozjpeg/archive/v4.0.3.tar.gz
- sha1sums = 8e9272a8ec1429638febd6897664c575bdd50ecb
+ source = mozjpeg-4.1.1.tar.gz::https://github.com/mozilla/mozjpeg/archive/v4.1.1.tar.gz
+ sha1sums = 2e061f93021f290c171816c4decd5a032fdfc2c8
pkgname = mozjpeg
diff --git a/PKGBUILD b/PKGBUILD
index e3db327e66ff..1bac635b3599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: N30N <archlinux@alunamation.com>
pkgname="mozjpeg"
-pkgver=4.0.3
+pkgver=4.1.1
pkgrel=2
pkgdesc="JPEG image codec with accelerated baseline decoding and superior encoding"
url="https://github.com/mozilla/mozjpeg"
@@ -14,7 +14,7 @@ arch=("i686" "x86_64" "armv7h")
depends=("glibc" "libpng")
makedepends=("nasm" "cmake")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha1sums=('8e9272a8ec1429638febd6897664c575bdd50ecb')
+sha1sums=('2e061f93021f290c171816c4decd5a032fdfc2c8')
provides=("libjpeg" "libjpeg.so=8-64" "turbojpeg" "libjpeg-turbo")
conflicts=("libjpeg" "mozjpeg-git" "turbojpeg" "libjpeg-turbo")
@@ -22,9 +22,6 @@ conflicts=("libjpeg" "mozjpeg-git" "turbojpeg" "libjpeg-turbo")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # Fix test: https://github.com/mozilla/mozjpeg/pull/415
- sed -i 's/--revert;arithmetic/-revert;-arithmetic/' CMakeLists.txt
-
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DENABLE_STATIC=FALSE -DPNG_SUPPORTED=TRUE -DWITH_JPEG8=TRUE .
make
}