summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorafontenot2022-03-08 17:59:05 -0800
committerafontenot2022-03-08 17:59:05 -0800
commit5bfd77ee7e89c8a093cb12c0e92b6d2b81fab738 (patch)
tree4f8b12d78ecbf444e62e91cfbd654a748a482b27
parent641b0f7fa861b6c171a56fa622488c430ad59123 (diff)
downloadaur-5bfd77ee7e89c8a093cb12c0e92b6d2b81fab738.tar.gz
Bump pkgrel for small changes
No need to update if you already have this built. This is so that the AUR database will pick up a new `provides` string. I've also cleaned up the mix of tabs and spaces previously used in the file, and fixed a broken test - these are now enabled by default.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD41
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ec62c4ba3cd..8a86da4eb885 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozjpeg
pkgdesc = JPEG image codec with accelerated baseline decoding and superior encoding
pkgver = 4.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mozilla/mozjpeg
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 49f0f9793aaf..e3db327e66ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname="mozjpeg"
pkgver=4.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="JPEG image codec with accelerated baseline decoding and superior encoding"
url="https://github.com/mozilla/mozjpeg"
license=("BSD")
@@ -20,25 +20,30 @@ provides=("libjpeg" "libjpeg.so=8-64" "turbojpeg" "libjpeg-turbo")
conflicts=("libjpeg" "mozjpeg-git" "turbojpeg" "libjpeg-turbo")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DENABLE_STATIC=FALSE -DPNG_SUPPORTED=TRUE -DWITH_JPEG8=TRUE .
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Fix test: https://github.com/mozilla/mozjpeg/pull/415
+ sed -i 's/--revert;arithmetic/-revert;-arithmetic/' CMakeLists.txt
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DENABLE_STATIC=FALSE -DPNG_SUPPORTED=TRUE -DWITH_JPEG8=TRUE .
+ make
}
-# much too slow for default, can be enabled if desired
-#check() {
-# cd "${srcdir}/${pkgname}-${pkgver}"
-# make test
-#}
+# There are a lot of tests: if you don't want to run them, you or
+# your AUR helper should use `makepkg --nocheck`.
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make test
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make \
- DESTDIR="${pkgdir}" \
- docdir="/usr/share/doc/${pkgname}" \
- exampledir="/usr/share/doc/${pkgname}" \
- install
-
- install -D LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -m644 jpegint.h "${pkgdir}/usr/include"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make \
+ DESTDIR="${pkgdir}" \
+ docdir="/usr/share/doc/${pkgname}" \
+ exampledir="/usr/share/doc/${pkgname}" \
+ install
+
+ install -D LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 jpegint.h "${pkgdir}/usr/include"
}