summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenny2015-10-01 18:13:52 +0200
committerLenny2015-10-01 18:13:52 +0200
commit054f769b1cd1d60d98a2ea568621e3ec76764700 (patch)
treed6537962f7c396f179ae1c1e71f9842227ececce
downloadaur-054f769b1cd1d60d98a2ea568621e3ec76764700.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37062ac1b01c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mp3check
+ pkgdesc = Check mp3 files for consistency plus fix header and id3tag errors
+ pkgver = 0.8.7
+ pkgrel = 1
+ url = https://code.google.com/p/mp3check/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ source = https://mp3check.googlecode.com/files/mp3check-0.8.7.tgz
+ md5sums = 83f5fd6514a55c88126725275aa2d1d5
+
+pkgname = mp3check
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e61a199de6b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Corelli <corelli AT yepmail DOT net>
+# Contributor: Gadget3000 <Gadget3000@msn.com>
+pkgname=mp3check
+pkgver=0.8.7
+pkgrel=1
+pkgdesc="Check mp3 files for consistency plus fix header and id3tag errors"
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/mp3check/"
+license=('GPL')
+source=(https://mp3check.googlecode.com/files/mp3check-${pkgver}.tgz)
+md5sums=(83f5fd6514a55c88126725275aa2d1d5)
+depends=(gcc-libs)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -D -m755 mp3check ${pkgdir}/usr/bin/mp3check
+}
+