summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuido2015-06-16 18:08:57 +0200
committerGuido2015-06-16 18:08:57 +0200
commit04c98b0ed1cdd9c9f4f182d34b424efa0760754b (patch)
tree43f9d7ffec689b9fa0c28067ff1e87e7058e5b2f
downloadaur-04c98b0ed1cdd9c9f4f182d34b424efa0760754b.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--mp3diags.install11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dabbbfaa676
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mp3diags
+ pkgdesc = Identify issues with your MP3 files, fix those issues and make other changes
+ pkgver = 1.2.02
+ pkgrel = 1
+ url = http://mp3diags.sourceforge.net/
+ install = mp3diags.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = boost-libs
+ depends = qt4
+ optdepends = mp3gain: MP3 normalization support
+ source = http://downloads.sourceforge.net/project/mp3diags/mp3diags-src/MP3Diags.tar.gz
+ sha1sums = 92b102713ac767ed45476c684f68f0d300fc8354
+
+pkgname = mp3diags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb3a5132f871
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jordi De Groof <jordi.degroof@gmail.com>
+# Contributors: Dan Serban, Dany Martineau, RTFreedman, Harvey
+
+pkgname=mp3diags
+pkgver=1.2.02
+pkgrel=1
+pkgdesc="Identify issues with your MP3 files, fix those issues and make other changes"
+url="http://mp3diags.sourceforge.net/"
+license=("GPL")
+arch=("i686" "x86_64")
+depends=("boost-libs" "qt4")
+makedepends=("boost")
+optdepends=('mp3gain: MP3 normalization support')
+install=mp3diags.install
+_unstabl="0"
+source=("http://downloads.sourceforge.net/project/mp3diags/mp3diags-src/MP3Diags.tar.gz")
+sha1sums=('92b102713ac767ed45476c684f68f0d300fc8354')
+# set to 1 to use the unstable version
+[ "$_unstabl" = "1" ] && pkgver=1.3.03
+[ "$_unstabl" = "1" ] && source=("http://sourceforge.net/projects/mp3diags/files/unstable/mp3diags-src/MP3Diags-unstable.tar.gz") ;
+[ "$_unstabl" = "1" ] && sha1sums=('9afee373045bf13dbded4eb2cd1b7edce90cb7dd') ;
+[ "$_unstabl" = "1" ] && _unstable=-unstable
+
+build() {
+ cd "${srcdir}/MP3Diags${_unstable}-${pkgver}"
+ ./AdjustMt.sh
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/MP3Diags${_unstable}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/usr/share/applications"
+ install -p -m755 "bin/MP3Diags${_unstable}" "${pkgdir}/usr/bin/"
+ install -p -m644 "desktop/MP3Diags${_unstable}.desktop" "${pkgdir}/usr/share/applications/"
+
+
+ for i in "16" "22" "24" "32" "36" "40" "48"; do
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps"
+ install -p -m644 "desktop/MP3Diags${_unstable}${i}.png" "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/MP3Diags${_unstable}.png"
+ done
+}
diff --git a/mp3diags.install b/mp3diags.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/mp3diags.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}