summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-08-22 12:43:53 +0200
committerwillemw122023-08-22 12:43:53 +0200
commit95994c9901f43c2bcc23aea69dc30e6b73301891 (patch)
treebf69ab0d48898eb3e652545135c9dfd32d65d6aa
parentaa34c305ac34bddb965f57d4fadb456744b4ed4d (diff)
downloadaur-95994c9901f43c2bcc23aea69dc30e6b73301891.tar.gz
Minor edits
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD36
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0a9eea551da..ef8f6d19f0a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mp3diags
- pkgdesc = Tool for finding and fixing problems in MP3 files; includes a tagger
+ pkgdesc = Find and fix problems in MP3 files. Includes a tagger
pkgver = 1.5.02
- pkgrel = 1
+ pkgrel = 2
url = https://mp3diags.sourceforge.net/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 01d1aa34f64f..480be1e6575a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer:
+# Maintainer: willemw <willemw12@gmail.com>
# Contributor: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Raphael Scholer <rascholer@gmail.com>
# Contributors: Dan Serban, Dany Martineau, RTFreedman, Harvey, Jordi De Groof, qqqqqqqqq9
+
pkgname=mp3diags
pkgver=1.5.02
-pkgrel=1
-pkgdesc="Tool for finding and fixing problems in MP3 files; includes a tagger"
-url="https://mp3diags.sourceforge.net/"
-license=('GPL2')
-arch=('x86_64')
-depends=('boost-libs' 'qt5-base')
-makedepends=('boost' 'qt5-tools')
+pkgrel=2
+pkgdesc='Find and fix problems in MP3 files. Includes a tagger'
+arch=(x86_64)
+url=https://mp3diags.sourceforge.net/
+license=(GPL2)
+depends=(boost-libs qt5-base)
+makedepends=(boost qt5-tools)
optdepends=('mp3gain: MP3 normalization support')
-source=("https://downloads.sourceforge.net/project/mp3diags/unstable/mp3diags-src/MP3Diags-unstable-${pkgver}.tar.gz")
+source=("https://downloads.sourceforge.net/project/mp3diags/unstable/mp3diags-src/MP3Diags-unstable-$pkgver.tar.gz")
sha256sums=('6dacea62988e7ffee79217cf404268ece22b3fee95474f021c22f854a9f3e8e6')
prepare() {
- cd "MP3Diags-unstable-$pkgver"
- sed -i 's/-unstable//g' desktop/MP3Diags-unstable.desktop
- sed -i 's/\/unstable//g' desktop/MP3Diags-unstable.desktop
+ sed -i 's|[-/]unstable||g' MP3Diags-unstable-$pkgver/desktop/MP3Diags-unstable.desktop
}
build() {
- cd "MP3Diags-unstable-$pkgver"
+ cd MP3Diags-unstable-$pkgver
./AdjustMt.sh
qmake-qt5
make
@@ -30,15 +29,14 @@ build() {
}
package() {
- cd "MP3Diags-unstable-$pkgver"
+ cd MP3Diags-unstable-$pkgver
+
install -Dm755 bin/MP3Diags-unstable "$pkgdir/usr/bin/MP3Diags"
- install -Dm644 desktop/MP3Diags-unstable.desktop \
- "$pkgdir/usr/share/applications/MP3Diags.desktop"
+ install -Dm644 desktop/MP3Diags-unstable.desktop "$pkgdir/usr/share/applications/MP3Diags.desktop"
for i in 16 22 24 32 36 40 48; do
- install -Dm644 "desktop/MP3Diags-unstable${i}.png" \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/MP3Diags.png"
+ install -Dm644 desktop/MP3Diags-unstable$i.png "$pkgdir/usr/share/icons/hicolor/${i}x$i/apps/MP3Diags.png"
done
- install -Dm644 src/translations/*.qm -t "$pkgdir/usr/share/mp3diags/translations/"
+ install -Dm644 src/translations/*.qm -t "$pkgdir/usr/share/mp3diags/translations"
}