summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeinrich Siebmanns2016-06-30 10:55:36 +0200
committerHeinrich Siebmanns2016-06-30 10:55:36 +0200
commit019e0791ac4d1602e72da3a50244b83a5c3c672e (patch)
treea02512142fb83623c24778b1b9d5e8f735cd57a4
parent30af305eead51a76de13c076bcbfd6100ea264e7 (diff)
downloadaur-019e0791ac4d1602e72da3a50244b83a5c3c672e.tar.gz
add patch to circumvent some C++ 11 changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--patch.diff51
3 files changed, 55 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31de35f8ccb4..43bdf0dd00b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mp3diags-unstable
pkgdesc = Identify issues with your MP3 files, fix those issues and make other changes
pkgver = 1.3.03
- pkgrel = 1
+ pkgrel = 2
url = http://mp3diags.sourceforge.net/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5d72d80387ea..3e992580cc17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Harvey <harv|at|gmx.de>
-# Contributors: Dan Serban, Dany Martineau, Jordi De Groof, RTFreedman
+# Contributors: Dan Serban, Dany Martineau, Jordi De Groof, RTFreedman, Ciobi (himself!)
pkgname="mp3diags-unstable"
pkgver="1.3.03"
-pkgrel=1
+pkgrel=2
pkgdesc="Identify issues with your MP3 files, fix those issues and make other changes"
url="http://mp3diags.sourceforge.net/"
license=("GPL")
@@ -15,6 +15,7 @@ source=("http://sourceforge.net/projects/mp3diags/files/unstable/mp3diags-src/MP
sha1sums=('9afee373045bf13dbded4eb2cd1b7edce90cb7dd')
build() {
+ patch -p 1 < ../patch.diff
cd "${srcdir}/MP3Diags-unstable-${pkgver}"
./AdjustMt.sh
qmake-qt4
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..e27dc88e20be
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,51 @@
+Only in old/: .directory
+diff -aur old/MP3Diags-unstable-1.3.03/src/ExportDlgImpl.cpp new/MP3Diags-unstable-1.3.03/src/ExportDlgImpl.cpp
+--- old/MP3Diags-unstable-1.3.03/src/ExportDlgImpl.cpp 2012-03-04 09:59:08.000000000 +0200
++++ new/MP3Diags-unstable-1.3.03/src/ExportDlgImpl.cpp 2016-06-29 13:58:59.071399156 +0300
+@@ -371,7 +371,7 @@
+ out << "\n\n";
+ }
+
+- return out;
++ return (bool)out;
+ }
+
+
+@@ -424,7 +424,7 @@
+ out << pCodec->fromUnicode(qs).constData() << endl;
+ }
+
+- return out;
++ return (bool)out;
+ }
+
+
+@@ -761,6 +761,6 @@
+
+ out << "</files>\n";
+
+- return out;
++ return (bool)out;
+ }
+
+diff -aur old/MP3Diags-unstable-1.3.03/src/MainFormDlgImpl.cpp new/MP3Diags-unstable-1.3.03/src/MainFormDlgImpl.cpp
+--- old/MP3Diags-unstable-1.3.03/src/MainFormDlgImpl.cpp 2015-03-08 19:04:11.000000000 +0200
++++ new/MP3Diags-unstable-1.3.03/src/MainFormDlgImpl.cpp 2016-06-29 13:37:47.284684767 +0300
+@@ -119,7 +119,7 @@
+ {
+ m_strFileName = strFileName;
+ ofstream_utf8 out (m_strFileName.c_str(), ios_base::app);
+- return out;
++ return (bool)out;
+ }
+
+ void close() { m_strFileName.clear(); }
+@@ -128,7 +128,7 @@
+ {
+ ofstream_utf8 out (m_strFileName.c_str(), ios_base::app);
+ out << s;
+- return out;
++ return (bool)out;
+ }
+ };
+ #else // #ifndef WIN32