summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-13 23:31:09 +0100
committerNarrat2020-01-13 23:31:09 +0100
commit0f98504c41067015c7b9b86f348bf2f7d192f8c3 (patch)
tree67d3150ae350ed29b60f2e793857c84fbf577d40
parent361f5147fb589f0c965f2c04371513b375d9822a (diff)
downloadaur-0f98504c41067015c7b9b86f348bf2f7d192f8c3.tar.gz
update to 2.27 and use architecture specific deps
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5882fecb5ff5..f216769653b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = mp3directcut
pkgdesc = fast audio editor and recorder for mp3 with no need to decompress
- pkgver = 2.24
+ pkgver = 2.27
pkgrel = 1
url = http://mpesch3.de1.cc/mp3dc.html
arch = i686
arch = x86_64
license = FREEWARE
- depends = wine
- depends = lib32-mpg123
- optdepends = lib32-libpulse: PulseAudio plugin
+ source = http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc227.exe
source = mp3directcut
source = mp3directcut.desktop
source = mp3dcicon.png
- source = http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc224.exe
+ md5sums = 506569cc40b1f2969645571f2cdaae8c
md5sums = 31de44159649baddf5c7b6936b87133f
md5sums = 910ada5caa9b0ea67a88bfc7ffe9c237
md5sums = 81a5bbd5789094b4bf5822791826c162
- md5sums = 17ba0eda4320095a14bc9d0f2eb9500b
+ depends_i686 = wine
+ depends_i686 = mpg123
+ optdepends_i686 = libpulse: PulseAudio plugin
+ depends_x86_64 = wine
+ depends_x86_64 = lib32-mpg123
+ optdepends_x86_64 = lib32-libpulse: PulseAudio plugin
pkgname = mp3directcut
diff --git a/PKGBUILD b/PKGBUILD
index 7ef9d5691677..60e11fe042d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,43 @@
-# Maintainer: Filip <fila pruda com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Filip <fila pruda com>
+
pkgname=mp3directcut
-pkgver=2.24
-_downver=224
+pkgver=2.27
pkgrel=1
pkgdesc="fast audio editor and recorder for mp3 with no need to decompress"
arch=('i686' 'x86_64')
url="http://mpesch3.de1.cc/mp3dc.html"
license=('FREEWARE')
-[ "$CARCH" = "i686" ] && depends=(wine mpg123)
-[ "$CARCH" = "x86_64" ] && depends=(wine lib32-mpg123)
-
-[ "$CARCH" = "i686" ] && optdepends=('libpulse: PulseAudio plugin')
-[ "$CARCH" = "x86_64" ] && optdepends=('lib32-libpulse: PulseAudio plugin')
+depends_i686=(wine mpg123)
+depends_x86_64=(wine lib32-mpg123)
+optdepends_i686=('libpulse: PulseAudio plugin')
+optdepends_x86_64=('lib32-libpulse: PulseAudio plugin')
+source=(http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc${pkgver/.}.exe
+ mp3directcut
+ mp3directcut.desktop
+ mp3dcicon.png)
+md5sums=('506569cc40b1f2969645571f2cdaae8c'
+ '31de44159649baddf5c7b6936b87133f'
+ '910ada5caa9b0ea67a88bfc7ffe9c237'
+ '81a5bbd5789094b4bf5822791826c162')
-makedepends=()
-source=(mp3directcut mp3directcut.desktop mp3dcicon.png http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc$_downver.exe)
-md5sums=(
- '31de44159649baddf5c7b6936b87133f' '910ada5caa9b0ea67a88bfc7ffe9c237'
- '81a5bbd5789094b4bf5822791826c162' '17ba0eda4320095a14bc9d0f2eb9500b')
package() {
-
#bin
install -Dm755 "mp3directcut" "$pkgdir/usr/bin/mp3directcut"
-
+
#app
install -d -m755 "$pkgdir/usr/share/mp3directcut"
install -m644 "mp3DirectCut.exe" "$pkgdir/usr/share/mp3directcut"
-
+
install -d -m755 "$pkgdir/usr/share/mp3directcut/Languages"
cp -r "Languages/." "$pkgdir/usr/share/mp3directcut/Languages"
-
+
#.desktop icon
install -Dm644 "mp3directcut.desktop" "$pkgdir/usr/share/applications/mp3directcut.desktop"
install -Dm644 "mp3dcicon.png" "$pkgdir/usr/share/pixmaps/mp3directcut.png"
-
+
#docs
install -d -m755 "$pkgdir/usr/share/doc/mp3directcut"
install -m644 *.txt *.htm "$pkgdir/usr/share/doc/mp3directcut"
-
-} \ No newline at end of file
+} \ No newline at end of file