summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormezcal2015-07-16 09:40:44 +0200
committermezcal2015-07-16 09:40:44 +0200
commitfedfe4ff1e36276366cc77318c6e20f339e077b0 (patch)
tree48e330e59588a1ca4088d0e26e95f834daaffec5
downloadaur-fedfe4ff1e36276366cc77318c6e20f339e077b0.tar.gz
Package imported from AUR3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--mp3dcicon.pngbin0 -> 3709 bytes
-rwxr-xr-xmp3directcut14
-rw-r--r--mp3directcut.desktop10
5 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6d82be1ca9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mp3directcut
+ pkgdesc = fast audio editor and recorder for mp3 with no need to decompress
+ pkgver = 2.20
+ pkgrel = 1
+ url = http://mpesch3.de1.cc/mp3dc.html
+ arch = i686
+ arch = x86_64
+ license = FREEWARE
+ source = mp3directcut
+ source = mp3directcut.desktop
+ source = mp3dcicon.png
+ source = http://mp.mpex.net/files/mp3DC220.exe
+ md5sums = 31de44159649baddf5c7b6936b87133f
+ md5sums = 910ada5caa9b0ea67a88bfc7ffe9c237
+ md5sums = a56a1f306e2c918f0e5f8b5cabdf8c1d
+ md5sums = 7159533de29017dca87f100f31d625bd
+
+pkgname = mp3directcut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6646259309f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Filip <fila pruda.com>
+pkgname=mp3directcut
+pkgver=2.20
+_downver=220
+pkgrel=1
+pkgdesc="fast audio editor and recorder for mp3 with no need to decompress"
+arch=('i686' 'x86_64')
+url="http://mpesch3.de1.cc/mp3dc.html"
+license=('FREEWARE')
+[ "$CARCH" = "i686" ] && depends=(wine mpg123)
+[ "$CARCH" = "x86_64" ] && depends=(wine lib32-mpg123)
+makedepends=()
+source=(mp3directcut mp3directcut.desktop mp3dcicon.png http://mp.mpex.net/files/mp3DC$_downver.exe)
+md5sums=(
+ '31de44159649baddf5c7b6936b87133f' '910ada5caa9b0ea67a88bfc7ffe9c237'
+ 'a56a1f306e2c918f0e5f8b5cabdf8c1d' '7159533de29017dca87f100f31d625bd')
+
+package() {
+
+ #bin
+ install -Dm755 "mp3directcut" "$pkgdir/usr/bin/mp3directcut"
+
+ #app
+ install -d -m755 "$pkgdir/usr/share/mp3directcut"
+ install -m644 "mp3DirectCut.exe" "$pkgdir/usr/share/mp3directcut"
+
+ install -d -m755 "$pkgdir/usr/share/mp3directcut/Languages"
+ cp -r "Languages/." "$pkgdir/usr/share/mp3directcut/Languages"
+
+ #.desktop icon
+ install -Dm644 "mp3directcut.desktop" "$pkgdir/usr/share/applications/mp3directcut.desktop"
+ install -Dm644 "mp3dcicon.png" "$pkgdir/usr/share/pixmaps/mp3directcut.png"
+
+ #docs
+ install -d -m755 "$pkgdir/usr/share/doc/mp3directcut"
+ install -m644 *.txt *.htm "$pkgdir/usr/share/doc/mp3directcut"
+
+} \ No newline at end of file
diff --git a/mp3dcicon.png b/mp3dcicon.png
new file mode 100644
index 000000000000..fc9ef3c7ec79
--- /dev/null
+++ b/mp3dcicon.png
Binary files differ
diff --git a/mp3directcut b/mp3directcut
new file mode 100755
index 000000000000..d48769d60a70
--- /dev/null
+++ b/mp3directcut
@@ -0,0 +1,14 @@
+#!/bin/bash
+
+export WINEDEBUG=-all # Supresses Wine debug messages
+
+if [ ! -d "$HOME"/.mp3directcut ] ; then
+ mkdir "$HOME"/.mp3directcut
+ #prepare the environment here
+
+ ln -s /usr/share/mp3directcut/mp3DirectCut.exe "$HOME"/.mp3directcut/mp3DirectCut.exe
+ ln -s -T /usr/share/mp3directcut/Languages "$HOME"/.mp3directcut/Languages
+
+fi
+
+wine "$HOME"/.mp3directcut/mp3DirectCut.exe "$@"
diff --git a/mp3directcut.desktop b/mp3directcut.desktop
new file mode 100644
index 000000000000..fc4f30a27606
--- /dev/null
+++ b/mp3directcut.desktop
@@ -0,0 +1,10 @@
+
+[Desktop Entry]
+Name=mp3DirectCut
+GenericName=fast mp3 audio editor
+Comment=fast and extensive audio editor and recorder for compressed mp3.
+Exec=mp3directcut
+Icon=mp3directcut
+Terminal=false
+Type=Application
+Categories=AudioVideo;Audio;AudioVideoEditing;Recorder;