summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2019-11-17 12:49:56 +1100
committerMatthew Gamble2019-11-17 12:51:07 +1100
commitf6d0c9e632dc4daa953263c673d4598863b01212 (patch)
treec2ad76f7c3f8d0c2c9e3875fc33f4a78a3bbd3c3
parent4e5a4c88d9f1ef9d784dc466f2d971e959216e8b (diff)
downloadaur-mp3fs-git.tar.gz
Big update
- Bump version number to take advantage of four years' worth of patches. Oops. - Upstream no longer has a dependency on the libb64 library (which wasn't packaged for arch at the time), so we can now safely include the vorbis picture support. - Code style cleanup. - Add gitignore file.
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d533e149543d..c496d727fb12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = mp3fs-git
pkgdesc = A read-only FUSE filesystem which transcodes audio formats (currently FLAC) to MP3 on the fly when opened and read.
- pkgver = 20150913
+ pkgver = 20191117
pkgrel = 1
url = http://khenriks.github.com/mp3fs/
- arch = i686
arch = x86_64
license = GPL
makedepends = git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72c6eb8af118
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.xz
+/mp3fs/
diff --git a/PKGBUILD b/PKGBUILD
index 38334dcc91c7..ed9b69054dcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,27 @@
# Contributor : Draje <draje@nullsum.net>
pkgname=mp3fs-git
-pkgver=20150913
+pkgver=20191117
pkgrel=1
pkgdesc="A read-only FUSE filesystem which transcodes audio formats (currently FLAC) to MP3 on the fly when opened and read."
-arch=('i686' 'x86_64')
+arch=("x86_64")
url="http://khenriks.github.com/mp3fs/"
-license=('GPL')
-depends=('fuse' 'flac' 'lame' 'libid3tag')
-makedepends=('git' 'asciidoc')
-conflicts=('mp3fs')
+license=("GPL")
+depends=("fuse" "flac" "lame" "libid3tag")
+makedepends=("git" "asciidoc")
+conflicts=("mp3fs")
source=('git://github.com/khenriks/mp3fs.git')
sha256sums=('SKIP')
build() {
- cd "$srcdir/mp3fs"
+ cd "$srcdir/mp3fs"
- ./autogen.sh
- ./configure --prefix=/usr \
- --without-vorbis-picture # There is no package for libb64 in Arch Linux as of today
- make || return 1
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
}
package() {
- cd "$srcdir/mp3fs"
- make PREFIX=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
+ cd "$srcdir/mp3fs"
+ make PREFIX=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
}