summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:01:37 +0100
committerBartłomiej Piotrowski2018-01-06 22:01:37 +0100
commitbc7a144f39e4b629f96a3364b0eefbf7ab945b98 (patch)
tree6cf07070d4e720e975dd2a42910ec46d4421fdd9
downloadaur-bc7a144f39e4b629f96a3364b0eefbf7ab945b98.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--build-fix.patch22
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98874acc72dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mp3gain
+ pkgdesc = Lossless mp3 normalizer with statistical analysis
+ pkgver = 1.5.2
+ pkgrel = 3
+ url = http://mp3gain.sourceforge.net
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/mp3gain/mp3gain-1_5_2-src.zip
+ source = build-fix.patch
+ md5sums = d888563538ec863eeea8afc8207b2739
+ md5sums = 20680cbada13ba941b0532ff94e583e1
+
+pkgname = mp3gain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..032255106e1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+# Contributor: keith <keith@hubbard.net>
+
+pkgname=mp3gain
+pkgver=1.5.2
+pkgrel=3
+pkgdesc="Lossless mp3 normalizer with statistical analysis "
+arch=('x86_64')
+url="http://mp3gain.sourceforge.net"
+license=("GPL")
+depends=('glibc')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-${pkgver//./_}-src.zip
+ build-fix.patch)
+md5sums=('d888563538ec863eeea8afc8207b2739'
+ '20680cbada13ba941b0532ff94e583e1')
+
+prepare() {
+ cd "$srcdir"
+ patch -p0 Makefile <"$srcdir"/build-fix.patch
+}
+
+build() {
+ cd "$srcdir"
+ make OSTYPE=linux
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/bin
+ make OSTYPE=linux INSTALL_PATH="$pkgdir"/usr/bin install
+}
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..6297f0a528d2
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,22 @@
+22d21
+< ifneq ($(OSTYPE),beos)
+24,26d22
+< else
+< INSTALL_PATH= $(HOME)/config/bin
+< endif
+28,29d23
+< # BeOS doesn't have libm (it's all in libroot)
+< ifneq ($(OSTYPE),beos)
+31,34d24
+< else
+< # BeOS: without this it wants to use bcopy() :^)
+< CFLAGS+= -DHAVE_MEMCPY
+< endif
+56,58d45
+< ifeq ($(OSTYPE),beos)
+< mimeset -f mp3gain$(EXE_EXT)
+< endif
+63,65d49
+< ifeq ($(OSTYPE),beos)
+< mimeset -f "$(INSTALL_PATH)/mp3gain$(EXE_EXT)"
+< endif