summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112018-07-27 09:58:41 +0200
committerjose17112018-07-27 09:58:41 +0200
commit3c13b1507f1bcd7fa5686a56eae02926c7d435f6 (patch)
tree9125d98817dc226125f2749e71534742285d70c6
downloadaur-3c13b1507f1bcd7fa5686a56eae02926c7d435f6.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2997b548398
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jul 27 07:58:25 UTC 2018
+pkgbase = mp4fixer-git
+ pkgdesc = Tool to recover damaged/unfinished mp4 files with h264 video
+ pkgver = r3.33d6351
+ pkgrel = 1
+ url = https://github.com/bookkojot/mp4fixer
+ arch = x86_64
+ arch = i686
+ license = GPL-3
+ makedepends = git
+ depends = perl
+ depends = faad2
+ conflicts = mp4fixer
+ source = mp4fixer-git::git+https://github.com/bookkojot/mp4fixer.git
+ md5sums = SKIP
+
+pkgname = mp4fixer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b99e57e91651
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=mp4fixer-git
+_pkgname=mp4fixer
+pkgver=r3.33d6351
+pkgrel=1
+pkgdesc="Tool to recover damaged/unfinished mp4 files with h264 video"
+url="https://github.com/bookkojot/mp4fixer"
+depends=('perl' 'faad2')
+makedepends=('git')
+conflicts=(mp4fixer)
+license=('GPL-3')
+arch=('x86_64' 'i686')
+source=("${pkgname}"::'git+https://github.com/bookkojot/mp4fixer.git')
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ gcc aac.c -L. -lfaad -lm -o aacfixer
+}
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -Dm755 aacfixer "${pkgdir}/usr/bin/aacfixer"
+ install -Dm755 montage.pl "${pkgdir}/usr/bin/montage.pl"
+ install -Dm755 fixer.pl "${pkgdir}/usr/bin/fixer.pl"
+}
+
+# vim:set ts=2 sw=2 et: