summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2020-10-26 11:26:39 +0100
committerJosip Ponjavic2020-10-26 11:26:39 +0100
commitaa277333a9b0e0d72aef0c047dc9eb9cca5e2b19 (patch)
treef7a11757fd569c6a5ea91a6fc6c2425ee30b8f92
parent29a9d25a956550f49cab6eef431f620eb42f7b0c (diff)
downloadaur-aa277333a9b0e0d72aef0c047dc9eb9cca5e2b19.tar.gz
upgpkg: 20.10-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2bec4155dfc..40ef82230fb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mpc-qt
pkgdesc = A clone of Media Player Classic reimplimented in Qt.
- pkgver = 19.06.g2abe6e7f
+ pkgver = 20.10
pkgrel = 1
- url = https://gitlab.com/mpc-qt/mpc-qt
+ url = https://github.com/cmdrkotori/mpc-qt-origin
arch = x86_64
license = GPL2
makedepends = git
@@ -12,8 +12,8 @@ pkgbase = mpc-qt
optdepends = libva-vdpau-driver: backend for Nvidia and AMD cards
optdepends = libva-intel-driver: backend for Intel cards
optdepends = udisks2: to detect available discs
- source = mpc-qt-19.06.g2abe6e7f.tar.bz2::https://gitlab.com/mpc-qt/mpc-qt/-/archive/2abe6e7fc643068d50522468fe75d614861555ad/mpc-qt-2abe6e7fc643068d50522468fe75d614861555ad.tar.bz2
- sha256sums = 2d1b1dfbd73123a93461ee98176d5b405c63b2d89021566ff025dda9c016998c
+ source = mpc-qt-origin-20.10.tar.gz::https://github.com/cmdrkotori/mpc-qt-origin/archive/v20.10.tar.gz
+ sha256sums = 325f3845e4ead9c6935c089c6321c8d0ea5097023de07ed2799e85a1f382d647
pkgname = mpc-qt
diff --git a/PKGBUILD b/PKGBUILD
index c594716989a6..03536bcd82c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,10 @@
# Contributor:
pkgname=mpc-qt
-pkgver=19.06.g2abe6e7f
+pkgver=20.10
pkgrel=1
-_commit=2abe6e7fc643068d50522468fe75d614861555ad
pkgdesc='A clone of Media Player Classic reimplimented in Qt.'
-url='https://gitlab.com/mpc-qt/mpc-qt'
+url='https://github.com/cmdrkotori/mpc-qt-origin'
arch=('x86_64')
license=('GPL2')
depends=('mpv' 'qt5-x11extras')
@@ -14,11 +13,11 @@ makedepends=('git' 'qt5-tools')
optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
'libva-intel-driver: backend for Intel cards'
'udisks2: to detect available discs')
-source=("${pkgname}-${pkgver}.tar.bz2::${url}/-/archive/${_commit}/${pkgname}-${_commit}.tar.bz2")
-sha256sums=('2d1b1dfbd73123a93461ee98176d5b405c63b2d89021566ff025dda9c016998c')
+source=("mpc-qt-origin-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('325f3845e4ead9c6935c089c6321c8d0ea5097023de07ed2799e85a1f382d647')
build() {
- cd "${pkgname}-${_commit}"
+ cd "mpc-qt-origin-${pkgver}"
qmake-qt5 PREFIX=/usr mpc-qt.pro \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
@@ -27,5 +26,5 @@ build() {
}
package() {
- make -C "${pkgname}-${_commit}" INSTALL_ROOT="${pkgdir}" install
+ make -C "mpc-qt-origin-${pkgver}" INSTALL_ROOT="${pkgdir}" install
}