summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2020-05-12 16:34:09 -0400
committeramoka2020-05-12 16:34:09 -0400
commit1e94d17c9c641e69baf3ffe75611a03f73988822 (patch)
treea6e5682abbeaf7c80a57194593647652181ecf4d
parent0a3d48e8ad5a8e94d08a756fa082cd468b128630 (diff)
downloadaur-1e94d17c9c641e69baf3ffe75611a03f73988822.tar.gz
adopt package and update PKGBUILD
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD95
2 files changed, 73 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa75e9344ab..b120464a21b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,48 @@
pkgbase = mpd-git
- pkgdesc = Flexible, powerful, server-side application for playing music
- pkgver = 0.20.23.r1494.g901229699
- pkgrel = 2
+ pkgdesc = Flexible, powerful, server-side application for playing music (from git)
+ pkgver = 0.21.23.r976.geeec0ee80
+ pkgrel = 1
url = https://www.musicpd.org/
arch = x86_64
license = GPL
makedepends = boost
- makedepends = doxygen
makedepends = meson
- depends = libao
- depends = ffmpeg
- depends = libmodplug
+ makedepends = liburing
+ makedepends = python-sphinx
depends = audiofile
- depends = libshout
- depends = libmad
+ depends = avahi
depends = curl
depends = faad2
- depends = sqlite
+ depends = ffmpeg
+ depends = fluidsynth
+ depends = icu
depends = jack
- depends = libmms
- depends = wavpack
- depends = avahi
+ depends = libao
+ depends = libcdio-paranoia
+ depends = libgme
depends = libid3tag
- depends = yajl
+ depends = libmad
+ depends = libmikmod
+ depends = libmms
+ depends = libmodplug
+ depends = libmpcdec
depends = libmpdclient
- depends = icu
- depends = libupnp
depends = libnfs
depends = libsamplerate
+ depends = libshout
depends = libsoxr
+ depends = libvorbis
+ depends = systemd-libs
+ depends = libupnp
+ depends = mpg123
+ depends = openal
depends = smbclient
- depends = libgme
+ depends = sqlite
+ depends = twolame
+ depends = wavpack
+ depends = wildmidi
+ depends = yajl
depends = zziplib
- depends = libsystemd
- depends = openal
- depends = mpg123
provides = mpd
conflicts = mpd
backup = etc/mpd.conf
diff --git a/PKGBUILD b/PKGBUILD
index fec99198e15e..3e0ee2ddb252 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-# Maintainer: E5ten <e5ten.arch@gmail.com>
-# Maintainer: anna <morganamilo@gmail.com>
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+# Contributor: E5ten <e5ten.arch@gmail.com>
+# Contributor: anna <morganamilo@gmail.com>
# Contributor: sudokode <sudokode@gmail.com>
# Contributor: graysky <graysky AT archlinux DOT us>
# Contributor: Slash <demodevil5[at]yahoo[dot]com>
@@ -9,20 +10,21 @@
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
# Contributor: Ben <ben@benmazer.net>
-
pkgname=mpd-git
_pkgname=mpd
-pkgver=0.20.23.r1494.g901229699
-pkgrel=2
-pkgdesc='Flexible, powerful, server-side application for playing music'
+pkgver=0.21.23.r976.geeec0ee80
+pkgrel=1
+pkgdesc='Flexible, powerful, server-side application for playing music (from git)'
url='https://www.musicpd.org/'
license=('GPL')
arch=('x86_64')
-depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl'
- 'faad2' 'sqlite' 'jack' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl'
- 'libmpdclient' 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr'
- 'smbclient' 'libgme' 'zziplib' 'libsystemd' 'openal' 'mpg123')
-makedepends=('boost' 'doxygen' 'meson')
+depends=('audiofile' 'avahi' 'curl' 'faad2' 'ffmpeg' 'fluidsynth'
+ 'icu' 'jack' 'libao' 'libcdio-paranoia' 'libgme' 'libid3tag' 'libmad'
+ 'libmikmod' 'libmms' 'libmodplug' 'libmpcdec' 'libmpdclient' 'libnfs'
+ 'libsamplerate' 'libshout' 'libsoxr' 'libvorbis' 'systemd-libs'
+ 'libupnp' 'mpg123' 'openal' 'smbclient' 'sqlite' 'twolame' 'wavpack'
+ 'wildmidi' 'yajl' 'zziplib')
+makedepends=('boost' 'meson' 'liburing' 'python-sphinx')
provides=('mpd')
conflicts=('mpd')
source=("$_pkgname::git+https://github.com/MusicPlayerDaemon/MPD"
@@ -36,52 +38,45 @@ sha256sums=('SKIP'
backup=('etc/mpd.conf')
-build() {
- arch-meson ${_pkgname} build \
- -Djack=enabled \
- -Ddsd=false \
- -Dlibmpdclient=enabled \
- -Dpipe=true \
- -Dpulse=enabled \
- -Dqobuz=disabled \
- -Dsoundcloud=enabled \
- -Dtidal=disabled \
- -Dzzip=enabled \
- -Dsidplay=disabled \
- -Dlibwrap=disabled \
- -Droar=disabled \
- -Dsndio=disabled \
- -Dchromaprint=disabled \
- -Dcdio_paranoia=disabled \
- -Diso9660=disabled \
- -Dadplug=disabled \
- -Dfluidsynth=disabled \
- -Dmikmod=disabled \
- -Dmpcdec=disabled \
- -Dwildmidi=disabled \
- -Dtwolame=disabled \
- -Dshine=disabled \
- -Dsystemd=enabled \
- -Dsystemd_system_unit_dir=/usr/lib/systemd/system \
- -Dsystemd_user_unit_dir=/usr/lib/systemd/user
+pkgver() {
+ cd "${_pkgname}"
- ninja -C build
+ git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+prepare() {
cd "${_pkgname}"
- install -Dm644 ../conf "${pkgdir}"/etc/mpd.conf
- install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
- install -Dm644 ../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
+ rm -fr build
+ install -d build
+}
- sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
- sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+build() {
+ cd "${_pkgname}/build"
+ _opts=('-Ddocumentation=true'
+ '-Dchromaprint=disabled' # appears not to be used for anything
+ '-Dsidplay=disabled' # unclear why but disabled in the past
+ '-Dadplug=disabled' # not in an official repo
+ '-Dsndio=disabled' # interferes with detection of alsa devices
+ '-Dshine=disabled' # not in an official repo
+ '-Dtremor=disabled' # not in an official repo
+ )
+ arch-meson .. ${_opts[@]}
+ ninja
}
+package() {
+ cd "${_pkgname}/build"
+ DESTDIR="${pkgdir}" ninja install
+ install -Dm644 ../doc/mpdconf.example "${pkgdir}"/usr/share/doc/mpd/mpdconf.example
+ install -Dm644 ../doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
+ install -Dm644 ../doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
-pkgver() {
- cd "${_pkgname}"
+ install -Dm644 ../../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -Dm644 ../../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
+ install -Dm644 ../../conf "${pkgdir}"/etc/mpd.conf
- git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
+ sed \
+ -e '/\[Service\]/a User=mpd' \
+ -e '/WantedBy=/c WantedBy=default.target' \
+ -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
}