summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2016-10-08 20:05:47 +0200
committerKenjiTakahashi2016-10-08 20:05:47 +0200
commit4045b56a5309fd3a2d2536e91539d1cb84f6b26d (patch)
treea35e3a0773537e8534af3a2798818dda66f00ed3
downloadaur-4045b56a5309fd3a2d2536e91539d1cb84f6b26d.tar.gz
INIT
-rw-r--r--.AURINFO35
-rw-r--r--.SRCINFO41
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD73
-rw-r--r--mpd.conf10
-rw-r--r--mpd.install11
-rw-r--r--mpd.tmpfile1
7 files changed, 174 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..845d1336927a
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,35 @@
+pkgbase = mpd-light
+ pkgdesc = Flexible, powerful, server-side application for playing music. Light version without ao, ffmpeg, jack, modplug, pulse, shout, sidplay, soundcloud, wavpack, avahi
+ pkgver = 0.19.4
+ pkgrel = 1
+ url = http://www.musicpd.org/
+ install = mpd.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = doxygen
+ makedepends = boost
+ depends = audiofile
+ depends = libmad
+ depends = curl
+ depends = faad2
+ depends = sqlite
+ depends = libmms
+ depends = libid3tag
+ depends = libmpdclient
+ depends = icu
+ depends = libupnp
+ depends = libnfs
+ provides = mpd=0.19.4
+ conflicts = mpd
+ replaces = mpd
+ backup = etc/mpd.conf
+ source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.4.tar.xz
+ source = mpd.tmpfile
+ source = mpd.conf
+ sha1sums = f0397d7e923cd11fef8dae238efe9ae9ff12120f
+ sha1sums = f4d5922abb69abb739542d8e93f4dfd748acdad7
+ sha1sums = fd581b976f4931abf9b849224dcb38a73af14af0
+
+pkgname = mpd-light
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f16d8219c402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Sat Oct 8 18:05:39 UTC 2016
+pkgbase = mpd-light-pulse
+ pkgdesc = Flexible, powerful, server-side application for playing music. Light version without ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, avahi, smbclient support.
+ pkgver = 0.19.19
+ pkgrel = 1
+ url = http://www.musicpd.org/
+ install = mpd.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL
+ makedepends = doxygen
+ makedepends = boost
+ depends = audiofile
+ depends = libmad
+ depends = curl
+ depends = faad2
+ depends = sqlite
+ depends = libmms
+ depends = libid3tag
+ depends = libmpdclient
+ depends = icu
+ depends = libupnp
+ depends = libnfs
+ depends = libsamplerate
+ depends = libsoxr
+ depends = libcdio-paranoia
+ provides = mpd=0.19.19
+ conflicts = mpd
+ replaces = mpd
+ backup = etc/mpd.conf
+ source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.19.tar.xz
+ source = mpd.tmpfile
+ source = mpd.conf
+ sha1sums = 8c281b823825cab6677cb142b564acbf09a2874d
+ sha1sums = f4d5922abb69abb739542d8e93f4dfd748acdad7
+ sha1sums = fd581b976f4931abf9b849224dcb38a73af14af0
+
+pkgname = mpd-light-pulse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d725ba4cf0d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d261da48b97c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
+# Contributor: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: Ben <ben@benmazer.net>
+
+pkgname=mpd-light-pulse
+pkgver=0.19.19
+pkgrel=1
+pkgdesc='Flexible, powerful, server-side application for playing music. Light version without ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, avahi, smbclient support.'
+url='http://www.musicpd.org/'
+license=('GPL')
+arch=('i686' 'x86_64' 'armv6h')
+depends=('audiofile' 'libmad' 'curl' 'faad2' 'sqlite' 'libmms' 'libid3tag' 'libmpdclient'
+ 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'libcdio-paranoia')
+makedepends=('doxygen' 'boost')
+provides=("mpd=$pkgver")
+conflicts=('mpd')
+replaces=('mpd')
+source=("http://www.musicpd.org/download/mpd/${pkgver%.*}/mpd-${pkgver}.tar.xz"
+ 'mpd.tmpfile'
+ 'mpd.conf')
+sha1sums=('8c281b823825cab6677cb142b564acbf09a2874d'
+ 'f4d5922abb69abb739542d8e93f4dfd748acdad7'
+ 'fd581b976f4931abf9b849224dcb38a73af14af0')
+backup=('etc/mpd.conf')
+install=mpd.install
+
+prepare() {
+ # Temporary; see FS#48372
+ install -d "${srcdir}"/pkg-config
+ ln -s /usr/lib/pkgconfig/libsystemd.pc "${srcdir}"/pkg-config/libsystemd-daemon.pc
+}
+
+build() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ export PKG_CONFIG_PATH="${srcdir}"/pkg-config
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-cdio-paranoia \
+ --enable-libmpdclient \
+ --disable-ao \
+ --disable-ffmpeg \
+ --disable-jack \
+ --disable-modplug \
+ --disable-shout \
+ --disable-sidplay \
+ --disable-soundcloud \
+ --disable-wavpack \
+ --with-zeroconf=no \
+ --disable-smbclient \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+
+ make
+}
+
+package() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ../mpd.conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../mpd.tmpfile "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd{,/playlists}
+
+ install -Dm644 "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+ sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+}
diff --git a/mpd.conf b/mpd.conf
new file mode 100644
index 000000000000..cbdee96f5fd7
--- /dev/null
+++ b/mpd.conf
@@ -0,0 +1,10 @@
+# See: /usr/share/doc/mpd/mpdconf.example
+
+user "mpd"
+group "audio"
+pid_file "/run/mpd/mpd.pid"
+db_file "/var/lib/mpd/mpd.db"
+state_file "/var/lib/mpd/mpdstate"
+playlist_directory "/var/lib/mpd/playlists"
+bind_to_address "127.0.0.1"
+#music_directory "/home/user/music"
diff --git a/mpd.install b/mpd.install
new file mode 100644
index 000000000000..12742b90aa4d
--- /dev/null
+++ b/mpd.install
@@ -0,0 +1,11 @@
+post_install() {
+ getent group mpd &>/dev/null || groupadd -r -g 45 mpd >/dev/null
+ getent passwd mpd &>/dev/null || useradd -r -u 45 -g mpd -d /var/lib/mpd -s /bin/false -G audio mpd >/dev/null
+ usr/bin/systemd-tmpfiles --create mpd.conf || true
+}
+
+post_remove() {
+ getent passwd mpd &>/dev/null && userdel mpd >/dev/null
+ getent group mpd &>/dev/null && groupdel mpd >/dev/null
+ true
+}
diff --git a/mpd.tmpfile b/mpd.tmpfile
new file mode 100644
index 000000000000..41c4e743a3a1
--- /dev/null
+++ b/mpd.tmpfile
@@ -0,0 +1 @@
+d /run/mpd 0755 mpd mpd