summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2019-05-05 20:04:24 +0200
committerKenjiTakahashi2019-05-05 20:04:24 +0200
commit5aa960cca6276224e7f24b5d467c742795fe8d5d (patch)
tree94e79b7d0034b8528b3331ef080ac9ca25002c4a
parent35cebd2dc1f0a658b30f4cda39cf96800c5081d5 (diff)
downloadaur-5aa960cca6276224e7f24b5d467c742795fe8d5d.tar.gz
0.21.8-1: Bumped version, disabled gme and mms
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6d3eeff61fe..ff7c040ad362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpd-light-pulse
- pkgdesc = Flexible, powerful, server-side application for playing music. Light version without libmpdclient, openal, ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, fluidsynth, avahi, smbclient, zziplib support.
- pkgver = 0.21.5
+ pkgdesc = Flexible, powerful, server-side application for playing music. Light version without libmpdclient, openal, ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, fluidsynth, avahi, smbclient, zziplib, gme, mms support.
+ pkgver = 0.21.8
pkgrel = 1
url = https://www.musicpd.org/
install = mpd.install
@@ -16,7 +16,6 @@ pkgbase = mpd-light-pulse
depends = curl
depends = faad2
depends = sqlite
- depends = libmms
depends = libid3tag
depends = libpulse
depends = icu
@@ -25,15 +24,14 @@ pkgbase = mpd-light-pulse
depends = libsamplerate
depends = libsoxr
depends = libcdio-paranoia
- depends = libgme
- provides = mpd=0.21.5
+ provides = mpd=0.21.8
conflicts = mpd
replaces = mpd
backup = etc/mpd.conf
- source = https://www.musicpd.org/download/mpd/0.21/mpd-0.21.5.tar.xz
+ source = https://www.musicpd.org/download/mpd/0.21/mpd-0.21.8.tar.xz
source = mpd.tmpfile
source = mpd.conf
- sha256sums = 247112eabf1b818a4052db7f0f5917ab00831ebc60a1ec3bf1154da4dc16a5c7
+ sha256sums = 23e083f11356c66bfb4a53c00568d370f57707df56496b299c414aaae59a9757
sha256sums = c1683ba35774c85e16c70e89f7e2ed1c09619512b1a273daabbd5e34d40439bd
sha256sums = e213c108cd0e076b5cc07091707ef75d74d9ac8c779d0c0128cd0aa69617f8a0
diff --git a/PKGBUILD b/PKGBUILD
index cb051f437187..7fb26e79cf8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,15 @@
# Contributor: Ben <ben@benmazer.net>
pkgname=mpd-light-pulse
-pkgver=0.21.5
+pkgver=0.21.8
_majorver=0.21
pkgrel=1
-pkgdesc='Flexible, powerful, server-side application for playing music. Light version without libmpdclient, openal, ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, fluidsynth, avahi, smbclient, zziplib support.'
+pkgdesc='Flexible, powerful, server-side application for playing music. Light version without libmpdclient, openal, ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, fluidsynth, avahi, smbclient, zziplib, gme, mms support.'
url='https://www.musicpd.org/'
license=('GPL')
arch=('i686' 'x86_64' 'armv6h')
-depends=('audiofile' 'libmad' 'curl' 'faad2' 'sqlite' 'libmms' 'libid3tag' 'libpulse'
- 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'libcdio-paranoia' 'libgme')
+depends=('audiofile' 'libmad' 'curl' 'faad2' 'sqlite' 'libid3tag' 'libpulse'
+ 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'libcdio-paranoia')
makedepends=('boost' 'meson' 'python-sphinx')
provides=("mpd=$pkgver")
conflicts=('mpd')
@@ -23,7 +23,7 @@ replaces=('mpd')
source=("https://www.musicpd.org/download/mpd/${_majorver}/mpd-${pkgver}.tar.xz"
'mpd.tmpfile'
'mpd.conf')
-sha256sums=('2ea9f0eb3a7bdae5d705adf4e8ec45ef38b5b9ddf133f32b8926dd4e205b0ef9'
+sha256sums=('23e083f11356c66bfb4a53c00568d370f57707df56496b299c414aaae59a9757'
'c1683ba35774c85e16c70e89f7e2ed1c09619512b1a273daabbd5e34d40439bd'
'e213c108cd0e076b5cc07091707ef75d74d9ac8c779d0c0128cd0aa69617f8a0')
backup=('etc/mpd.conf')
@@ -42,10 +42,10 @@ build() {
_opts=('-Ddocumentation=true'
'-Dchromaprint=disabled' # appears not to be used for anything
'-Dsidplay=disabled' # unclear why but disabled in the past
- '-Dlibwrap=disabled' # twentieth century's over
'-Dadplug=disabled' # not in an official repo
'-Dsndio=disabled' # interferes with detection of alsa devices
'-Dshine=disabled' # not in an official repo
+ '-Dtremor=disabled' # not in an official repo
'-Dao=disabled'
'-Dffmpeg=disabled'
'-Djack=disabled'
@@ -60,6 +60,8 @@ build() {
'-Dlibmpdclient=disabled'
'-Dopenal=disabled'
'-Dfluidsynth=disabled'
+ '-Dmms=disabled'
+ '-Dgme=disabled'
)
arch-meson --auto-features auto .. ${_opts[@]}
ninja