summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Gorodinsky2019-04-16 16:24:15 +0300
committerEugene Gorodinsky2019-04-16 16:24:30 +0300
commitf8e3bda07b33537f1605375b9da24a2c5ee3ea1d (patch)
treead0b3fbaf93b7672e958ed1fe21012dd7a60def3
parent61621bcb244254eaec0a077f5d93ab6e28b0dda6 (diff)
downloadaur-f8e3bda07b33537f1605375b9da24a2c5ee3ea1d.tar.gz
add ffmpeg patch
-rw-r--r--PKGBUILD4
-rw-r--r--ffmpeg.patch11
2 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7287252ea82c..9be39c0025b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,7 @@ install=mpd.install
prepare() {
cd "${srcdir}/mpd-${pkgver}"
patch --input="${srcdir}/../meson.patch"
+ patch -p0 -R --input="${srcdir}/../ffmpeg.patch"
install -d build
}
@@ -66,7 +67,6 @@ build() {
'-Dsmbclient=disabled'
'-Dnfs=disabled'
'-Dcdio_paranoia=disabled'
- '-Dcurl=disabled'
'-Dmms=disabled'
# cloud
@@ -88,7 +88,6 @@ build() {
'-Dmodplug=disabled'
'-Dsidplay=disabled' # unclear why but disabled in the past
'-Dwavpack=disabled'
- '-Dffmpeg=disabled'
'-Daudiofile=disabled'
'-Dfaad=disabled'
'-Dflac=disabled'
@@ -120,7 +119,6 @@ build() {
'-Dhttpd=false'
'-Drecorder=false'
'-Doss=disabled'
- '-Dalsa=disabled'
'-Dopenal=disabled'
'-Dpulse=disabled'
'-Dshout=disabled'
diff --git a/ffmpeg.patch b/ffmpeg.patch
new file mode 100644
index 000000000000..89f1865db6ac
--- /dev/null
+++ b/ffmpeg.patch
@@ -0,0 +1,11 @@
+--- src/input/plugins/FfmpegInputPlugin.cxx
++++ src/input/plugins/FfmpegInputPlugin.cxx
+@@ -118,8 +118,6 @@ static constexpr const char *ffmpeg_prefixes[] = {
+ "rtmp://",
+ "rtmpt://",
+ "rtmps://",
+- "http://",
+- "https://",
+ nullptr
+ };
+