summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2015-09-26 13:03:58 +0200
committerBruno Pagani2015-09-26 13:03:58 +0200
commit0aa7c62e101c3d640a731c0d699c5b14d53b1e7a (patch)
tree62fea19ec39fac856eed2d91c8a594539e5fd82e
downloadaur-0aa7c62e101c3d640a731c0d699c5b14d53b1e7a.tar.gz
Initial upload: mpd-minimal 0.19.10-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD103
-rw-r--r--mpd.conf6
-rw-r--r--mpd.install11
-rw-r--r--mpd.tmpfile1
5 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..786d42c0d055
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = mpd
+ pkgdesc = Flexible, powerful, server-side application for playing music. Minmal version with only flac playback through socket connection.
+ pkgver = 0.19.10
+ pkgrel = 1
+ url = http://www.musicpd.org/
+ install = mpd.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = alsa-lib
+ depends = flac
+ depends = icu
+ depends = libmpdclient
+ depends = libsystemd
+ depends = sqlite
+ provides = mpd=0.19.10
+ conflicts = mpd
+ replaces = mpd
+ backup = etc/mpd.conf
+ source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.10.tar.xz
+ source = mpd.tmpfile
+ source = mpd.conf
+ sha1sums = 4635b33223d3f1e67eed41f6350ef75515153213
+ sha1sums = f4d5922abb69abb739542d8e93f4dfd748acdad7
+ sha1sums = 291fd5cda9f0845834a553017327c4586bd853f6
+
+pkgname = mpd-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1a1388aa8e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,103 @@
+# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani at gmail dot com>
+
+pkgbase=mpd
+pkgname=mpd-minimal
+pkgver=0.19.10
+pkgrel=1
+pkgdesc='Flexible, powerful, server-side application for playing music. Minmal version with only flac playback through socket connection.'
+url='http://www.musicpd.org/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('alsa-lib' 'flac' 'icu' 'libmpdclient' 'libsystemd' 'sqlite')
+makedepends=('boost')
+provides=("mpd=$pkgver")
+conflicts=('mpd')
+replaces=('mpd')
+source=("http://www.musicpd.org/download/mpd/${pkgver%.*}/mpd-${pkgver}.tar.xz"
+ 'mpd.tmpfile'
+ 'mpd.conf')
+sha1sums=('4635b33223d3f1e67eed41f6350ef75515153213'
+ 'f4d5922abb69abb739542d8e93f4dfd748acdad7'
+ '291fd5cda9f0845834a553017327c4586bd853f6')
+backup=('etc/mpd.conf')
+install=mpd.install
+
+build() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-libmpdclient \
+ --disable-ao \
+ --disable-httpd-output \
+ --disable-jack \
+ --disable-openal \
+ --disable-oss \
+ --disable-pulse \
+ --disable-recorder-output \
+ --disable-roar \
+ --disable-shout \
+ --disable-aac \
+ --disable-adplug \
+ --disable-audiofile \
+ --disable-ffmpeg \
+ --disable-fluidsynth \
+ --disable-gme \
+ --disable-mad \
+ --disable-mikmod \
+ --disable-modplug \
+ --disable-mpc \
+ --disable-mpg123 \
+ --disable-opus \
+ --disable-sidplay \
+ --disable-sndfile \
+ --disable-vorbis \
+ --disable-wavpack \
+ --disable-wildmidi \
+ --disable-curl \
+ --disable-expat \
+ --disable-ipv6 \
+ --disable-libwrap \
+ --disable-mms \
+ --disable-nfs \
+ --disable-smbclient \
+ --disable-soundcloud \
+ --disable-tcp \
+ --disable-upnp \
+ --disable-bzip2 \
+ --disable-iso9660 \
+ --disable-zlib \
+ --disable-zzip \
+ --disable-cdio-paranoia \
+ --disable-id3 \
+ --disable-largefile \
+ --disable-lsr \
+ --disable-soxr \
+ --disable-lame-encoder \
+ --disable-shine-encoder \
+ --disable-twolame-encoder \
+ --disable-vorbis-encoder \
+ --disable-wave-encoder \
+ --disable-neighbor-plugins \
+ --enable-sqlite \
+ --enable-systemd-daemon \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-zeroconf=no
+
+ make
+}
+
+package() {
+ cd "${srcdir}/mpd-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+# install -Dm644 ../mpd.conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../mpd.tmpfile "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+# install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd/{,playlists}
+
+ install -Dm644 "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+ sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+}
diff --git a/mpd.conf b/mpd.conf
new file mode 100644
index 000000000000..da7d6fae92eb
--- /dev/null
+++ b/mpd.conf
@@ -0,0 +1,6 @@
+# See: /usr/share/doc/mpd/mpdconf.example
+
+pid_file "/run/mpd/mpd.pid"
+db_file "/var/lib/mpd/mpd.db"
+state_file "/var/lib/mpd/mpdstate"
+playlist_directory "/var/lib/mpd/playlists"
diff --git a/mpd.install b/mpd.install
new file mode 100644
index 000000000000..12742b90aa4d
--- /dev/null
+++ b/mpd.install
@@ -0,0 +1,11 @@
+post_install() {
+ getent group mpd &>/dev/null || groupadd -r -g 45 mpd >/dev/null
+ getent passwd mpd &>/dev/null || useradd -r -u 45 -g mpd -d /var/lib/mpd -s /bin/false -G audio mpd >/dev/null
+ usr/bin/systemd-tmpfiles --create mpd.conf || true
+}
+
+post_remove() {
+ getent passwd mpd &>/dev/null && userdel mpd >/dev/null
+ getent group mpd &>/dev/null && groupdel mpd >/dev/null
+ true
+}
diff --git a/mpd.tmpfile b/mpd.tmpfile
new file mode 100644
index 000000000000..41c4e743a3a1
--- /dev/null
+++ b/mpd.tmpfile
@@ -0,0 +1 @@
+d /run/mpd 0755 mpd mpd