summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2016-12-25 03:37:08 +0100
committerBruno Pagani2016-12-25 03:37:08 +0100
commit9db42c9fc8bc7599b69d95aa7f6b80294d9b8af7 (patch)
treebdb4a64d72dd07d8c50c3e97b2f4f056614e5af8
parente72fabd66b2d157c69373fdd6b8239f26e815766 (diff)
downloadaur-9db42c9fc8bc7599b69d95aa7f6b80294d9b8af7.tar.gz
upgpkg: mpd-minimal 0.19.21-1
Upstream release + improve PKGBUILD. Make use of variables as much as possible. Switch to https. Fix wrong use of `replaces`. Reorganize ./configure arguments. Disable some more useless things for this setup. Only provide systemd user service.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD99
2 files changed, 63 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b791538ab8fb..3aa982e8e097 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mpd
- pkgdesc = Flexible, powerful, server-side application for playing music. Minimal version with only flac playback through socket connection as user, but configurable.
- pkgver = 0.19.19
+ pkgdesc = Flexible, powerful, server-side application for playing music. Minimal version with only flac playback through socket connection as user.
+ pkgver = 0.19.21
pkgrel = 1
- url = http://www.musicpd.org/
+ url = https://www.musicpd.org/
arch = i686
arch = x86_64
arch = armv7h
@@ -14,13 +14,12 @@ pkgbase = mpd
depends = icu
depends = libmpdclient
depends = sqlite
- provides = mpd=0.19.19
+ provides = mpd=0.19.21
conflicts = mpd
- replaces = mpd
- source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.19.tar.xz
- source = http://www.musicpd.org/download/mpd/0.19/mpd-0.19.19.tar.xz.sig
+ source = https://www.musicpd.org//download/mpd/0.19/mpd-0.19.21.tar.xz
+ source = https://www.musicpd.org//download/mpd/0.19/mpd-0.19.21.tar.xz.sig
validpgpkeys = 0392335A78083894A4301C43236E8A58C6DB4512
- sha1sums = 8c281b823825cab6677cb142b564acbf09a2874d
+ sha1sums = 27dd903f4f7c0f5ffeb85e6820c02d2b82485572
sha1sums = SKIP
pkgname = mpd-minimal
diff --git a/PKGBUILD b/PKGBUILD
index 8363f011e2ad..7e3501827ce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani@gmail.com>
pkgbase=mpd
-pkgname=mpd-minimal
-pkgver=0.19.19
+pkgname=${pkgbase}-minimal
+pkgver=0.19.21
pkgrel=1
-pkgdesc='Flexible, powerful, server-side application for playing music. Minimal version with only flac playback through socket connection as user, but configurable.'
-url='http://www.musicpd.org/'
+pkgdesc="Flexible, powerful, server-side application for playing music. Minimal version with only flac playback through socket connection as user."
+url="https://www.musicpd.org/"
license=('GPL')
arch=('i686' 'x86_64' 'armv7h')
-depends=('alsa-lib' 'flac' 'glib2' 'icu' 'libmpdclient' 'sqlite') # 'libsystemd'
+depends=('alsa-lib' 'flac' 'glib2' 'icu' 'libmpdclient' 'sqlite')
makedepends=('boost')
-provides=("mpd=$pkgver")
-conflicts=('mpd')
-replaces=('mpd')
-validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512')
-source=("http://www.musicpd.org/download/mpd/${pkgver%.*}/mpd-${pkgver}.tar.xz"{,.sig})
-sha1sums=('8c281b823825cab6677cb142b564acbf09a2874d' 'SKIP')
+provides=("${pkgbase}=$pkgver")
+conflicts=("${pkgbase}")
+source=("${url}/download/${pkgbase}/${pkgver%.*}/${pkgbase}-${pkgver}.tar.xz"{,.sig})
+sha1sums=('27dd903f4f7c0f5ffeb85e6820c02d2b82485572' 'SKIP')
+validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512') # Max Kellermann
build() {
- cd "${srcdir}/mpd-${pkgver}"
+ cd ${pkgbase}-${pkgver}
- ./configure \
+ ./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --enable-libmpdclient \
- --disable-ao \
- --disable-httpd-output \
- --disable-jack \
- --disable-openal \
- --disable-oss \
- --disable-pulse \
- --disable-recorder-output \
- --disable-roar \
- --disable-shout \
+ --disable-bzip2 \
+ --disable-iso9660 \
+ --disable-zlib \
+ --disable-zzip \
+ --disable-ipv6 \
+ --disable-tcp \
+ --enable-un \
+ --disable-largefile \
+ --disable-nfs \
+ --disable-smbclient \
--disable-aac \
--disable-adplug \
--disable-audiofile \
+ --disable-dsd \
--disable-ffmpeg \
--enable-flac \
--disable-fluidsynth \
@@ -51,41 +51,54 @@ build() {
--disable-vorbis \
--disable-wavpack \
--disable-wildmidi \
- --disable-curl \
- --disable-expat \
- --disable-ipv6 \
- --disable-libwrap \
+ --disable-id3 \
+ --disable-ao \
+ --enable-alsa \
+ --enable-fifo \
+ --disable-httpd-output \
+ --disable-jack \
--disable-mms \
- --disable-nfs \
- --disable-smbclient \
- --disable-soundcloud \
- --disable-tcp \
- --disable-upnp \
- --disable-bzip2 \
- --disable-iso9660 \
- --disable-zlib \
- --disable-zzip \
+ --disable-openal \
+ --disable-oss \
+ --disable-osx \
+ --disable-pipe-output \
+ --disable-pulse \
+ --disable-recorder-output \
+ --disable-roar \
+ --disable-shout \
+ --disable-solaris-output \
--disable-cdio-paranoia \
- --disable-id3 \
- --disable-largefile \
- --disable-lsr \
- --disable-soxr \
+ --disable-curl \
+ --disable-soundcloud \
--disable-lame-encoder \
--disable-shine-encoder \
--disable-twolame-encoder \
--disable-vorbis-encoder \
--disable-wave-encoder \
+ --disable-lsr \
+ --disable-soxr \
--disable-neighbor-plugins \
+ --disable-upnp \
+ --disable-expat \
+ --disable-libwrap \
+ --disable-debug \
+ --disable-test \
+ --disable-documentation \
+ --disable-inotify \
+ --enable-libmpdclient \
+ --enable-database \
--enable-sqlite \
+ --enable-icu \
+ --enable-glib \
--disable-systemd-daemon \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-systemduserunitdir=/usr/lib/systemd/user \
+ --without-systemdsystemunitdir \
--with-zeroconf=no
-
make
}
package_mpd-minimal() {
- cd "${srcdir}/mpd-${pkgver}"
+ cd ${pkgbase}-${pkgver}
make DESTDIR="${pkgdir}" install
}