summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-10-08 20:59:29 +0200
committerBruno Pagani2017-10-08 20:59:29 +0200
commitb16801c4abf138803ad49b138f01409b1e63b5b2 (patch)
tree6d90749bf6a2138d9e1b6fc3c73d36190b48438f
parent0a73e482883d2d14d0512fcc88ff432c6a6a20cc (diff)
downloadaur-b16801c4abf138803ad49b138f01409b1e63b5b2.tar.gz
Enhance systemd support
systemd-daemon support or `Type=simple` is required to make it work. Also remove useless permissions and cie. from the unit file.
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 775481792ee1..284a446397b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -94,7 +94,7 @@ build() {
--enable-daemon \
--enable-sqlite \
--enable-icu \
- --disable-systemd-daemon \
+ --enable-systemd-daemon \
--with-systemduserunitdir=/usr/lib/systemd/user \
--without-systemdsystemunitdir \
--with-zeroconf=no
@@ -105,4 +105,6 @@ package() {
cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+ sed -e 's/network.target //g' -e 's/AF_INET AF_INET6 AF_UNIX AF_NETLINK/AF_UNIX/g' -i "${pkgdir}"/usr/lib/systemd/user/mpd.service
+
}