summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-07-03 12:39:22 +0200
committerChristian Hesse2015-07-03 12:39:22 +0200
commitc3a0f32b8da371b0c91513ecc27c745bcc9b08ad (patch)
treedd1b154c1c58f23d936c1e6182ef135f36d71cd9
parentbd354e7bced50743a451584deb74636adbd53066 (diff)
downloadaur-c3a0f32b8da371b0c91513ecc27c745bcc9b08ad.tar.gz
commit mpd-notification-git 0.6.0.r3.ge05895b-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e64dfe3d80e..2fbf60c16259 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpd-notification-git
pkgdesc = Notify about tracks played by mpd - git checkout
- pkgver = 0.5.2.r6.g53787fc
+ pkgver = 0.6.0.r3.ge05895b
pkgrel = 1
url = https://github.com/eworm-de/mpd-notification
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3a899ecc1605..338b00740c5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=mpd-notification-git
-pkgver=0.5.2.r6.g53787fc
+pkgver=0.6.0.r3.ge05895b
pkgrel=1
pkgdesc='Notify about tracks played by mpd - git checkout'
arch=('i686' 'x86_64')
@@ -10,14 +10,20 @@ depends=('ffmpeg' 'libnotify' 'libmpdclient' 'gnome-icon-theme')
makedepends=('git' 'markdown')
license=('GPL')
source=('git://github.com/eworm-de/mpd-notification.git')
+sha256sums=('SKIP')
pkgver() {
cd mpd-notification/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count)" \
+ "$(git log -1 --format='%h')"
fi
}
@@ -33,4 +39,3 @@ package() {
make DESTDIR="${pkgdir}" install
}
-sha256sums=('SKIP')