summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Jouve2020-04-25 13:30:10 -0400
committerJean Jouve2020-04-25 13:30:10 -0400
commitc4de2b432ab72404fd018d4ae94b0f22315c33ec (patch)
tree4490e82dab20a604e23b365be4bdc53e2fa1336d
downloadaur-c4de2b432ab72404fd018d4ae94b0f22315c33ec.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb3b1b496f09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mpd-notification-time-git
+ pkgdesc = Notify about tracks played by mpd. Prints time and notify on received signal.
+ pkgver = 0.8.5.r25.336d088
+ pkgrel = 1
+ url = https://github.com/poroing/mpd-notification
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = systemd
+ makedepends = markdown
+ depends = libsystemd
+ depends = ffmpeg
+ depends = file
+ depends = iniparser
+ depends = libnotify
+ depends = libmpdclient
+ provides = mpd-notification
+ conflicts = mpd-notification
+ source = mpd-notification-time::git+https://github.com/Poroing/mpd-notification.git
+ md5sums = SKIP
+
+pkgname = mpd-notification-time-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..944f16353cb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jean Jouve <jean.jouve at protonmail dot com>
+
+pkgname=mpd-notification-time-git
+pkgver=0.8.5.r25.336d088
+pkgrel=1
+pkgdesc="Notify about tracks played by mpd. Prints time and notify on received signal."
+arch=('x86_64' 'i686')
+url="https://github.com/poroing/mpd-notification"
+license=('GPL')
+depends=('libsystemd' 'ffmpeg' 'file' 'iniparser' 'libnotify' 'libmpdclient')
+makedepends=('git' 'systemd' 'markdown')
+provides=('mpd-notification')
+conflicts=('mpd-notification')
+source=('mpd-notification-time::git+https://github.com/Poroing/mpd-notification.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}