summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2022-11-08 07:40:45 +0100
committergoreleaserbot2022-11-08 07:40:45 +0100
commit9bc57dc6c079f0fda89d740500a5d16e93095a71 (patch)
tree4a36d7372f79516ac2eb2377010e3f9e8f06f5a9
downloadaur-9bc57dc6c079f0fda89d740500a5d16e93095a71.tar.gz
Update to v0.7.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7375656945d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mpd-rich-presence-bin
+ pkgdesc = Service to display the currently playing song in MPD as your Discord Rich Presence.
+ pkgver = 0.7.0
+ pkgrel = 1
+ license = MIT
+ depends = mpd
+ conflicts = mpd-rich-presence
+ provides = mpd-rich-presence
+ arch = aarch64
+ source_aarch64 = https://github.com/nekowinston/mpd-rich-presence/releases/download/v0.7.0-1/mpd-rich-presence_0.7.0-1_linux_arm64.tar.gz
+ sha256sums_aarch64 = 8eda0ee553cb33dd485419cd4718e1c24ae60fcf23024c15f0c650e5d9ff19bd
+ arch = x86_64
+ source_x86_64 = https://github.com/nekowinston/mpd-rich-presence/releases/download/v0.7.0-1/mpd-rich-presence_0.7.0-1_linux_amd64.tar.gz
+ sha256sums_x86_64 = eee53637a054a1f2da5d41eaa30bb31798842b625b4c5c83382db9c812655670
+
+pkgname = mpd-rich-presence-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b83321417eb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: nekowinston <hey@winston.sh>
+# Contributor: nekowinston <hey@winston.sh>
+
+pkgname='mpd-rich-presence-bin'
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='Service to display the currently playing song in MPD as your Discord Rich Presence.'
+url=''
+arch=('aarch64' 'x86_64')
+license=('MIT')
+provides=('mpd-rich-presence')
+conflicts=('mpd-rich-presence')
+depends=('mpd')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/nekowinston/mpd-rich-presence/releases/download/v0.7.0-1/mpd-rich-presence_0.7.0-1_linux_arm64.tar.gz")
+sha256sums_aarch64=('8eda0ee553cb33dd485419cd4718e1c24ae60fcf23024c15f0c650e5d9ff19bd')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/nekowinston/mpd-rich-presence/releases/download/v0.7.0-1/mpd-rich-presence_0.7.0-1_linux_amd64.tar.gz")
+sha256sums_x86_64=('eee53637a054a1f2da5d41eaa30bb31798842b625b4c5c83382db9c812655670')
+
+package() {
+ # bin
+ install -Dm755 "./mpd-rich-presence" "${pkgdir}/usr/bin/mpd-rich-presence"
+ # license
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/mpd-rich-presence/LICENSE"
+ # service
+ install -Dm644 "./mpd-rich-presence.service" "${pkgdir}/usr/lib/systemd/user/mpd-rich-presence.service"
+}