summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMelvin Vermeeren2019-01-04 04:45:13 +0100
committerMelvin Vermeeren2019-01-04 04:45:13 +0100
commite0eee516383d123c88179a789615f1548a8242f8 (patch)
tree11799706a0c28a52f23c166e8ab66315dd7723ab
parent9548429086182bbf03a7f29dc4c3c2b65e74a57f (diff)
downloadaur-e0eee516383d123c88179a789615f1548a8242f8.tar.gz
update to 0.21.4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD72
-rw-r--r--sysusers.d2
-rw-r--r--tmpfiles.d2
4 files changed, 55 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fa5bda1fb6c..a735b4a23a45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Tue Oct 30 13:57:14 UTC 2018
+# Fri Jan 4 02:47:58 UTC 2019
pkgbase = mpd-sacd
pkgdesc = MPD with patches for SACD and DVDA ISO playback.
- pkgver = 0.21.0
- pkgrel = 10
+ pkgver = 0.21.4
+ pkgrel = 1
url = https://sourceforge.net/p/sacddecoder/mpd/MPD.git/ci/master/tree/
- install = install
arch = i686
arch = x86_64
arch = aarch64
arch = armv7h
license = GPL
makedepends = boost
- makedepends = doxygen
+ makedepends = meson
+ makedepends = python-sphinx
depends = libao
depends = ffmpeg
depends = libmodplug
@@ -38,14 +38,16 @@ pkgbase = mpd-sacd
depends = libcdio-paranoia
depends = libgme
depends = zziplib
- provides = mpd=0.21.0
+ provides = mpd=0.21.4
conflicts = mpd
backup = etc/mpd.conf
- source = mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=5690d1d9a6a61e0b90ad6d58b89838c2275959e1
+ source = mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=3934b0b6c769cc4817f628c6b55fab130eb22d97
+ source = sysusers.d
source = tmpfiles.d
source = conf
sha1sums = SKIP
- sha1sums = f4d5922abb69abb739542d8e93f4dfd748acdad7
+ sha1sums = 7c7de7b30c6c8e1c705dd415692f6a08a3f62c82
+ sha1sums = d82864959d1a1a07bf75d87c7586dbb713892f3a
sha1sums = 291fd5cda9f0845834a553017327c4586bd853f6
pkgname = mpd-sacd
diff --git a/PKGBUILD b/PKGBUILD
index df21ad4b212b..42651ee1cccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Melvin Vermeeren <mail@mel.vin>
pkgname=mpd-sacd
-pkgver=0.21.0
-pkgrel=10
+pkgver=0.21.4
+pkgrel=1
pkgdesc='MPD with patches for SACD and DVDA ISO playback.'
url='https://sourceforge.net/p/sacddecoder/mpd/MPD.git/ci/master/tree/'
license=('GPL')
@@ -11,48 +11,58 @@ depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl' 'f
'sqlite' 'jack' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl' 'libmpdclient'
'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'smbclient' 'libcdio-paranoia'
'libgme' 'zziplib')
-makedepends=('boost' 'doxygen')
+makedepends=('boost' 'meson' 'python-sphinx')
conflicts=('mpd')
provides=("mpd=${pkgver}")
-source=('mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=5690d1d9a6a61e0b90ad6d58b89838c2275959e1'
+source=('mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=3934b0b6c769cc4817f628c6b55fab130eb22d97'
+ 'sysusers.d'
'tmpfiles.d'
'conf')
sha1sums=('SKIP'
- 'f4d5922abb69abb739542d8e93f4dfd748acdad7'
+ '7c7de7b30c6c8e1c705dd415692f6a08a3f62c82'
+ 'd82864959d1a1a07bf75d87c7586dbb713892f3a'
'291fd5cda9f0845834a553017327c4586bd853f6')
-
backup=('etc/mpd.conf')
-install=install
-build() {
+prepare() {
cd "${srcdir}/mpd"
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-cdio-paranoia \
- --enable-iso9660 \
- --enable-jack \
- --enable-libmpdclient \
- --enable-pipe-output \
- --enable-pulse \
- --enable-soundcloud \
- --enable-zzip \
- --disable-sidplay \
- --with-systemduserunitdir=/usr/lib/systemd/user \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --enable-sacdiso \
- --enable-dvdaiso
+ rm -rf build
+ install -d build
+}
- make
+build() {
+ cd "${srcdir}/mpd/build"
+ _opts=('-Ddocumentation=true'
+ '-Dchromaprint=disabled' # appears not to be used for anything
+ '-Dsidplay=disabled' # unclear why but disabled in the past
+ '-Dadplug=disabled' # not in an official repo
+ '-Dsndio=disabled' # interferes with detection of alsa devices
+ '-Dshine=disabled' # not in an official repo
+ '-Dcdio_paranoia=enabled'
+ '-Diso9660=enabled'
+ '-Djack=enabled'
+ '-Dlibmpdclient=enabled'
+ '-Dpipe=true'
+ '-Dpulse=enabled'
+ '-Dsoundcloud=enabled'
+ '-Dzzip=enabled'
+ '-Dsacdiso=true'
+ '-Ddvdaiso=true'
+ )
+ arch-meson .. ${_opts[@]}
+ ninja
}
package() {
- cd "${srcdir}/mpd"
- make DESTDIR="${pkgdir}" install
- install -Dm644 ../conf "${pkgdir}"/etc/mpd.conf
- install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
- install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd{,/playlists}
+ cd "${srcdir}/mpd/build"
+ DESTDIR="${pkgdir}" ninja install
+ install -Dm644 ../doc/mpdconf.example "${pkgdir}"/usr/share/doc/mpd/mpdconf.example
+ install -Dm644 ../doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
+ install -Dm644 ../doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
+
+ install -Dm644 ../../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
+ install -Dm644 ../../conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
diff --git a/sysusers.d b/sysusers.d
new file mode 100644
index 000000000000..58d47478ea69
--- /dev/null
+++ b/sysusers.d
@@ -0,0 +1,2 @@
+u mpd 45 - /var/lib/mpd
+m mpd audio
diff --git a/tmpfiles.d b/tmpfiles.d
index 41c4e743a3a1..bef72182b228 100644
--- a/tmpfiles.d
+++ b/tmpfiles.d
@@ -1 +1,3 @@
d /run/mpd 0755 mpd mpd
+d /var/lib/mpd 0755 mpd mpd
+d /var/lib/mpd/playlists 0755 mpd mpd